User Cannot Change Profile
Symptoms
A particular user cannot make any changes to their profile. When on the "Profile" page, the entire menu on the left (Labels, Watches, Drafts, Settings) is missing. The user belongs to the same groups as others, that work just fine.
Cause
The user account was created using Confluence's remote API. Hence usual checks for valid usernames effective when adding the user via the UI, were not applicable. Hence this user was created with an additional whitespace (blank) at the end. The logs indicated the URL as:
http://<Base URL>/admin/users/viewuser.action?username=<Useranme>%2B
Instead of the expected:
http://<Base URL>/admin/users/viewuser.action?username=<Username>
Resolution
Rename the username to remove the whitespace.