User directory sync fails with LDAP Error Code 49

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This Knowledge Base article was written specifically for the Atlassian Server platform. Due to the Restricted functions in Atlassian Cloud apps, the contents of this article cannot be applied to Atlassian Cloud applications.

Symptoms

Users are unable to log in. The following appears in the atlassian-confluence.log:

atlassian-confluence.log
javax.naming.AuthenticationException: [LDAP: error code 49 - 80090308: LdapErr: DSID-0C0903A9, comment: AcceptSecurityContext error, data 701, v1db0]

Causes

There could be many reasons for this issue. Please check the error's number and "data" code (in the example above, error code 49 and data code 701) and match it with the description in the following table:

Data Code

Description

525

user not found

52e

invalid credentials

530

not permitted to logon at this time

531

not permitted to logon at this workstation

532

password expired (remember to check the user set in osuser.xml also)

533

account disabled

701

account expired

773

user must reset password

775

user account locked

In the example above, the error code is 701 (account expired).

Resolution

Check the table above for a specific diagnosis. Since the issue is often originated from Active Directory, once you have the diagnosis, consult with your LDAP or Active Directory administrator for resolution.

(info) Please see our Troubleshooting LDAP User Management documentation for further assistance with diagnosing LDAP problems.

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