User Getting Logged Out Intermittently Due to the Groupname Case Change in LDAP

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Platform notice: Server and Data Center only. This article only applies to Atlassian products on the Server and Data Center platforms.

Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.

*Except Fisheye and Crucible

Problem

  1. User session, JSESSIONID is being refreshed from the browser cookies.
  2. Intermittent permission access loss - user cannot view page intermittently due to insufficient permission.
  3. The following appears in the atlassian-confluence.log.

    2015-06-08 04:07:55,679 WARN [scheduler_Worker-10] [atlassian.crowd.directory.DbCachingRemoteChangeOperations] findGroupsToUpdate remote group name [ Sample Group ] casing differs from local group name [ sample group ]. Group details will be kept updated, but the group name cannot be updated

Diagnosis

Diagnostic Steps

  1. Perform a full synchronization on LDAP user directory.
  2. Check with the log file.

Cause

User is removed from a particular group (which has a certain permission) when a user directory synchronization is executed.

Workaround

  1. Revert the character case (of the LDAP Group Name) back to the original ones.
  2. In this example, Sample Group should change back to sample group.
  3. Perform another full synchronization on LDAP user directory and check if there is any errors from atlassian-confluence.log.

Last modified on Apr 12, 2023

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