Using the Advanced Roadmaps for Jira in Confluence macro results in an "Update Jira's base URL" warning

Still need help?

The Atlassian Community is here for you.

Ask the community


Platform Notice: Server and Data Center Only - This article only applies to Atlassian products on the server and data center platforms.

Summary

When embedding an Advanced Roadmaps for Jira in Confluence macro on a Confluence page, Confluence displays an "Update Jira's base URL" warning.

Environment

Confluence 6.15.4

Jira 7.7.1

Macro versions:

In Confluence: Version 1.2 Advanced Roadmaps for Jira in Confluence

In Jira: Version 3.19.1 Advanced Roadmaps (formerly Portfolio)

Diagnosis

When either configuring the Advanced Roadmaps for Jira in Confluence macro or viewing a page that contains it, Confluence displays a pop-up box like the following which indicates that the Jira base URL needs updating:

Cause

This problem has been found to be caused by a mismatch in add-on versions between the Advanced Roadmaps for Jira in Confluence add-on and the Advanced Roadmaps (formerly Portfolio) add-on in which a newer version of the former will not work properly with an older version of the latter. 

Solution

In this case, the Advanced Roadmaps (formerly Portfolio) add-on needed to be upgraded to a newer version.  In order to do so, however, the Jira core product needed to be upgraded first to Jira version 8.

Last modified on Oct 1, 2020

Was this helpful?

Yes
No
Provide feedback about this article
Powered by Confluence and Scroll Viewport.