When applying a new license key to Confluence, I get an error XSRF check failed

Still need help?

The Atlassian Community is here for you.

Ask the community

Platform notice: Server and Data Center only. This article only applies to Atlassian products on the Server and Data Center platforms.

Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.

*Except Fisheye and Crucible

    

Summary

XSRF check failed error message appears when updating the license in Confluence

Environment

  • Confluence Server and Data Center

Diagnosis

When applying a new License to Confluence, we get the error as below:

Cause

The most common cause is that the Server Base URL is not matching the one you are using to access Confluence.

Solution

  1. Please make sure that you have the same Base URL you are using to access your instance;
    1. This is the most common issue.
  2. Something might not be correctly configured in your proxy if you are using any. For further reference, please check this document:
  3. We might want to disable temporarily the XSRF check on Confluence as mentioned in this document - Configuring XSRF protection
  4. We might want to bypass the proxy if you have any and access Confluence directly to manually update it;
  5. We, of course, can always have the ability to change the license manually through the confluence.cfg.xml file:




Last modified on Mar 9, 2021

Was this helpful?

Yes
No
Provide feedback about this article
Powered by Confluence and Scroll Viewport.