Crowd Server Fails to Send E-mails
Symptoms
When setting the email configurations using the Crowd Admin Console (not a JNDI email resource), Crowd attempts to send an email and the process fails causing the following message to be recorded in the logs:
Could not send email to email@example.com. Reason:Invalid Addresses
Cause
The SMTP Server requires authentication. However Crowd is not setting its SMTP messages to authenticate.
Resolution
Solution 1
Modify Crowd's <Crowd-Install>/apache-tomcat/bin/setenv.bat (or setenv.sh if Linux) file, adding the following parameter to the JAVA_OPTS:
-Dmail.smtp.auth=true
For example:
set JAVA_OPTS=%JAVA_OPTS% -Xms128m -Xmx256m -Dmail.smtp.auth=true -Dfile.encoding=UTF-8
Then, restart Crowd.
Solution 2
Instead of using the normal UI configuration, use a JNDI Resource.