Active directory user(s) show as disabled in Crowd despite being enabled in AD

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Platform notice: Server and Data Center only. This article only applies to Atlassian products on the Server and Data Center platforms.

Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.

*Except Fisheye and Crucible

Summary

After full sync with Active Directory, active AD accounts display as disabled in Crowd.

Environment

Crowd 3.4.4

Diagnosis

To verify if this article workaround is applicable, we will run a SQL query in Confluence database:

SELECT * FROM CWD_USER WHERE DIRECTORY_ID = <ID> and active = 0
    • This will show that the account(s) in question have a "0" value for the "active" column

In Crowd, go to "Users" and locate an affected disabled user. Click on it and navigate to the "Applications" tab.

    • The Applications tab will be blank even though the user is a member of one or more active Crowd applications

If any results are returned then you could be affected by this issue. To confirm, check the results for any known active users.

Cause

The root cause for this is unknown at this time and will be reported when identified.

Workaround

Click the "Save" button in the "Applications" tab of the affected user.

This action should refresh the Applications screen, and all assigned applications will be visible. The account in question and all other erroneously disabled accounts should now be active. 


Last modified on Mar 8, 2021

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