Logging in to Crowd Keeps Failing and Gets Redirected Back to The Login Page

Still need help?

The Atlassian Community is here for you.

Ask the community

Symptoms

When a user tries to log in to Crowd, the authentication keeps failing without any error message, and instead user keeps getting redirected to login page again.

Cause

The SSO Domain for the cookies has changed while users are still logged in. Indicators include

  1. There are duplicate crowd.token_key cookies
  2. Secure SSO cookies option is enabled
  3. The SSO domain name in the General option is wrongly set

Resolution

  1. Shut down Crowd
  2. Clear your browser cookies
  3. Execute the following SQL query:

    UPDATE cwd_property SET property_value='false' WHERE property_name='secure.cookie';
  4. Execute the following SQL query:

    UPDATE cwd_property SET property_value=NULL where property_name='domain';
  5. Restart Crowd.


Please be aware that when having the domain wrongly set, the application link to Crowd will also receive the same behaviour as when logging in Crowd.

 

 

Last modified on Feb 23, 2016

Was this helpful?

Yes
No
Provide feedback about this article
Powered by Confluence and Scroll Viewport.