Unable to complete Crowd setup wizard due to invalid server base URL

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Platform notice: Server and Data Center only. This article only applies to Atlassian products on the Server and Data Center platforms.

Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.

*Except Fisheye and Crucible

Problem

The Crowd Setup Wizard is stuck on the screen configuring a Default Administrator.

The Crowd logs register the following error:

java.net.UnknownHostException: myserver: myserver
	at java.net.InetAddress.getLocalHost(InetAddress.java:1425)
	at com.atlassian.crowd.console.action.setup.DefaultAdministrator.addCrowdApplication(DefaultAdministrator.java:218)
	at com.atlassian.crowd.console.action.setup.DefaultAdministrator.doUpdate(DefaultAdministrator.java:108)
	at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
	at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:57)
	at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
	at java.lang.reflect.Method.invoke(Method.java:616)

Cause

The Base URL specified in the steps before is unresolvable and therefore, it is unable to add an Administrator account.

Resolution

  1. Shutdown Crowd
  2. Remove the CROWD_HOME folder (not the CROWD Installation folder)
  3. Start Crowd again
  4. When you arrive at the step specifying a Base URL, input, ensure you use http://localhost:8095/crowd

The Base URL configured here is what the Crowd Console will use to communicate to the Crowd Server. Since they are usually on the same server, using localhost generally works.

 

 

 

 

 

 

 

 

 

 

 

 

 

   

 

 

 

 

 

 

 

 

 

 

 

 

 

Last modified on Nov 20, 2015

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