Unable to Import Users Into a Directory Due to Tomcat Session Already Invalidated

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Symptoms

When importing a large number of users or groups into a directory in Crowd, the import fails after a long time with a system error.

The following appears on screen and also in the atlassian-crowd.log:

2012-03-21 06:37:49,576 http-8095-4 INFO [atlassian.xwork.interceptors.TransactionalInvocation] Invoking rollback for transaction on action '/console/secure/dataimport/directoryconfirmation.action (DirectoryConfirmation.execute())' due to throwable: java.lang.IllegalStateException: getAttribute: Session already invalidated

Cause

The amount of time it took to perform the directory import exceeded Tomcat's session-timeout value (which is set to 30 minutes by default). This issue is tracked here:  CWD-2638 - Getting issue details... STATUS

Workaround

  1. Make a note of how long it takes before the import fails.
  2. Locate and open <crowd_install>/apache-tomcat/conf/web.xml in a text editor.
  3. Locate the following line and increase the numeric value (in minutes) as necessary to accomodate the import (currently set to 30 in this example):

     <session-timeout>30</session-timeout>

    (info) For more details on the Tomcat web.xml, please see: http://tomcat.apache.org/tomcat-6.0-doc/appdev/web.xml.txt

Resolution

This issue is being tracked here:  CWD-2638 - Getting issue details... STATUS

Last modified on Mar 30, 2016

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