Skip to end of metadata
Go to start of metadata

Upgrading from GreenHopper 5.8.x to 5.9

Please follow the upgrade instructions in the JIRA Agile Installation and Upgrade Guide, plus note the following:

JIRA 5.0 is required

GreenHopper 5.9 is only compatible with JIRA 5.0.

If upgrading from 5.8.3, manual upgrade is required

If you are upgrading from GreenHopper 5.8.3, please:

  1. Download GreenHopper manually from the Plugin Exchange.
  2. Install it using the instructions for 'Installing your own plugin' — see Managing JIRA's Plugins.

Other known issues

Before you begin the upgrade, please check for known issues. Sometimes we find out about a problem with the latest version of GreenHopper after we have released the software. In such cases we publish information about the known issues in the GreenHopper Knowledge Base. Please check for known issues and follow the instructions as necessary.

If you encounter a problem during the upgrade and cannot solve it, please create a support ticket and one of our support engineers will help you.

Upgrading from GreenHopper 5.7.x or earlier

In addition to the above, please read the GreenHopper 5.7 Upgrade Notes and the Upgrade Guide for every version you are skipping during the upgrade. The complete list of Upgrade Guides is available here.

Re-index and re-start required

Please re-index and re-start JIRA after ugrading to GreenHopper 5.9 from GreenHopper 5.7.x or earlier.