Child pages
  • JIRA Agile Fails to Upgrade when running JIRA with Java Version 6
Skip to end of metadata
Go to start of metadata

The license could not be verified: License Certificate has expired! Administrators, please check your license details here.

Platform Notice: Server and Data Center Only - This article only applies to Atlassian products on the server and data center platforms.

Problem

When an attempt to upgrade JIRA Agile to version 6.7.6 or higher, the upgrade fails and the plugin does not start.  

  • When accessing the JIRA Agile add-on in the Universal Plugin Manager, a warning banner is shown stating: This add-on couldn't be loaded. It has one or more errors that prevent it from beiong enabled
  • The JIRA Agile Add-On can not be enabled.

The following appears in the atlassian-jira.log

2015-07-07 10:10:10,010 ThreadPoolAsyncTaskExecutor::Thread 27 ERROR superman 1015x562510x2 196e3wr 10.10.10.10 /rest/plugins/1.0/installed-marketplace [plugin.osgi.factory.OsgiPlugin] Unable to start the plugin container for plugin com.pyxis.greenhopper.jira
org.springframework.beans.factory.UnsatisfiedDependencyException: Error creating bean with name 'tx-annotation-processor' defined in URL [bundle://161.0:0/META-INF/spring/atlassian-plugins-components.xml]: Unsatisfied dependency expressed through constructor argument with index 0 of type [com.atlassian.activeobjects.external.ActiveObjects]: : Error loading class [com.atlassian.pocketknife.spi.querydsl.DefaultDialectConfiguration] for bean with name 'defaultDialectConfiguration' defined in URL [bundle://161.0:1/com/atlassian/pocketknife/spi/querydsl/DefaultDialectConfiguration.class]: problem with class file or dependent class; nested exception is java.lang.UnsupportedClassVersionError: com/atlassian/pocketknife/spi/querydsl/DefaultDialectConfiguration : Unsupported major.minor version 51.0; nested exception is org.springframework.beans.factory.CannotLoadBeanClassException: Error loading class [com.atlassian.pocketknife.spi.querydsl.DefaultDialectConfiguration] for bean with name 'defaultDialectConfiguration' defined in URL [bundle://161.0:1/com/atlassian/pocketknife/spi/querydsl/DefaultDialectConfiguration.class]: problem with class file or dependent class; nested exception is java.lang.UnsupportedClassVersionError: com/atlassian/pocketknife/spi/querydsl/DefaultDialectConfiguration : Unsupported major.minor version 51.0

Diagnosis

Environment

  • Running on an unsupported version of Java as per Supported Platforms for your specific version of JIRA.

Diagnostic Steps

  • Check the atlassian-jira.log for errors revering to Unsupported major.minor version 51.0
  • Reviewing the SystemSystem Info, Under Java Version page indicates a version of JIRA lower than Java 1.7.0 (For example 1.6.0_25)

Cause

Recent versions versions of JIRA are not supported to run on Java 6. See:|Supported Platforms. Specifically the error message: Unsupported major.minor version 51.0.  indicates that the new source code in the Add-On requires Java version 7 or higher to run. 

Workaround

If you are unable to Upgrade JIRA to a Supported version, to get JIRA Agile to work, you will need to downgrade JIRA Agile to an older version. (Such as JIRA Agile 6.6.80).

  1. Uninstall the JIRA Agile Plugin from the Universal Plugin Manager. (See: Uninstalling apps)
  2. Install an older version of JIRA Agile by Uploading a previous version found at: JIRA Agile Versions

Resolution

  1. Download and install a more recent version of Java 7, or even better Java 8 from:http://www.oracle.com/technetwork/java/javase/downloads/jre8-downloads-2133155.html Check your JIRA Version's Supported Platforms to confirm which version should be installed.
  2. Update the Java Version being used as per: How to Use System JRE Instead of Embedded JRE
Help us improve!

  • No labels