Child pages
  • Unable to set issues to Resolved using JIRA Agile Simplified Workflow
Skip to end of metadata
Go to start of metadata

Symptoms

Issues being dragged to Done status in the Rapid Board (Work Mode) are left with a Unresolved Resolution field status.

Cause

This was caused by a known issue as tracked under  GHS-5741 - Getting issue details... STATUS If a project was created from JIRA and later converted to Simplified Workflow, the Resolution field is not configured. This will lead to all Issues having a Resolution of Unresolved.

(info) If the project was created directly from JIRA Agile Getting Started page, it will already use the Simplified Workflow and the workflow will already handle setting of the Resolved status when issues are moved to the last column.

Resolution

Upgrade to JIRA Agile (formerly GreenHopper) 6.2.5 or higher, as GHS-5741 - Getting issue details... STATUS has now been fixed. If you are unable to upgrade the version of JIRA Agile, follow the workaround below.

Workaround

Method 1 - This workaround will configure a transition screen where the Resolution field is manually set by the user:

  1. (Download/Behind-the-Firewall ONLY): Backup your JIRA instance (Administration > Backup data to XML).
  2. Go to workflow configuration in Administration > Issues > Workflows
  3. Edit the workflow (this will create a draft of it) and click on the Resolved Global Transition:
     
  4. Click on the Post Functions tab:
  5. Delete the post function that is set to clear the Resolution field for the Global Transitions:
  6. Edit the transition, as below:
  7. Set a Transition View. The Resolve Issue Screen will let you specify the resolution when this transition is used.
  8. After updating the screen, publish the draft of the workflow - this will migrate all your issues from the old to the new workflow. Ensure to save a backup copy!
     
  9. Repeat steps 3-8 for the Closed Global Transition.
  10. When moving an issue from a column to Done now has a transition screen where the Resolution field can be set by the user:

Method 2 - This workaround will automatically set the Resolution field to Fixed:

 Click here to expand...
  1. Go to workflow configuration in Administration > Issues > Workflows
    1.1 Make a copy of the problem workflow and click on 'Edit' to edit the Resolved and Closed transitions (The reason to make a copy of the workflow is to prevent you losing current data. You will be able to rollback your current instance if any wrong steps taken.)

    1.2. Remove the post function that is set to clear the Resolution field for both Resolved and Closed transition..
    1.3 Add a post function that will set the Resolution field to Fixed(using the post function 'Update Issue Field'):

    For Transition 'Resolved':

    For Transition 'Closed':

2. When moving an issue from a column to Done now will automatically set the Resolution field to Fixed, as configured in the post function.

 3. Associate with the related Workflow Schemes and projects. Configuring workflow schemes

 

(info) There may be other transitions in the workflow that has a similar post function set to clear the Resolution. To resolve this; Remove the post function that is set to clear the Resolution field from any other transitions.

Additional Information

In case if this KB does not fix the problem, please feel free to contact our support via https://support.atlassian.com by create an issue with an XML backup of your database (Administration > Backup data to XML) so that we can try to reproduce the problem here for further investigate. You can anonymise your data if you wish by going to [http://confluence.atlassian.com/display/JIRA/Anonymising+data?utm_source=support].

7 Comments

  1. I have JIRA Agile v6.6.0 and I'm still seeing this problem. Are there any other permanent fixes for this issue?

  2. I'm seeing this issue as well in version 6.2.4.

    Is there anyone at Atlassian listening in on this page?  If not, is there an issue opened that will address this bug in the future?

    1. Hi Erik ZwerlingTrace Windham,

      This problem should have been fixed in JIRA Agile 6.2.5 as mentioned in  GHS-5741 - Getting issue details... STATUS .

      If you are still seeing the problem on versions higher than that, please create a ticket on support.atlassian.com so we can investigate the cause and fix it.

      Cheers

      1. Thanks Marcus,

        Looks like I'm on JIRA 6.2.4.  I just noticed that fix version right after I submitted the comment.  

        I'll start working with my group here at my office to get us upgraded to the latest version of JIRA.

        Thanks again,

        Trace

        1. Hey Trace Windham,

          Please note the fix was applied to version 6.2.5 of JIRA Agile, not JIRA itself.

          JIRA Agile 6.2.5 is only compatible with JIRA 6.0.8 so I'm assuming you already have a version newer than 6.2.5 for JIRA Agile and should already have the fix applied to that bug ticket.

          If that is the case, please create a support ticket with us so we can investigate further.

          Cheers

          1. Thanks Marcus Silveira

            I didn't think to check the version of JIRA Agile, and it turns out that I am running version 6.6.13 of JIRA Agile.

            I'll be glad to submit a more detailed bug report soon.

            Thanks again,

            Trace Windham

      2. Hi Marcus,

        Thanks for the update, but I'm still experiencing the bug with my current setup and I have a JIRA Agile version greater than 6.2.5.  My versions I'm using are:

        • JIRA: v6.1.6
        • JIRA Agile: v6.6.0

        I'll file a separate ticket for this, but hopefully it can be fixed ASAP as this bug is causing major tracking problems for multiple projects in my company.

        Thanks,

        Erik Zwerling