This documentation relates to Application Links 2.1.x
If you are using an earlier version, please view the previous versions of the AppLinks documentation and select the relevant version.

Skip to end of metadata
Go to start of metadata
Icon

Application Links is not supported by Atlassian. Many customers have reported issues with it, and compatibility varies by point release of Atlassian products.

We recommend you do not install AppLinks. We are working on a 3.0 release of AppLinks which will completely revamp the product. This will be bundled with our products, so you won't need to install it separately. As a bonus, it'll actually work.

This page tells you how to install the Application Links (AppLinks) plugin into your Atlassian products.

On this page:

Step 1. Check the System Requirements

Components

You will need the following products to make use of Application Links:

Version Compatibility Matrix

The matrix below shows the applications that support AppLinks. The applications are listed horizontally across the top and the AppLinks versions are listed vertically on the left.

(info) Version numbers in brackets, e.g. (3.0.1), show a future application release expected to support the relevant AppLinks version.

 

Confluence

Crucible

FishEye

JIRA

Subversion

AppLinks 1.1

(tick) 2.8.x

(tick) 1.5.x

(tick) 1.5.x

(tick) 3.12.x

(tick) 1.4

AppLinks 1.3

(tick) 2.8.x
(tick) 2.9.x
(tick) 2.10.x
(warning) Confluence 3.0.0 does not support Application Links.

(tick) 1.5.x
(warning) Crucible 1.6.x does not support Application Links.

(tick) 1.5.x
(warning) FishEye 1.6.x does not support Application Links.

(tick) 3.12.x
(tick) 3.13.0
(warning) JIRA 3.13.1 to 3.13.4 do not support Application Links.

(tick) 1.4

AppLinks 2.0.1

(tick) 3.0.1

(tick) 2.0.0

(tick) 2.0.0

(tick) 3.13.5

(tick) 1.4

AppLinks 2.1

(tick) 3.0.1

(tick) 2.0.0

(tick) 2.0.0

(tick) 4.0

(tick) 1.4

Other useful links:

Step 2. Download the AppLinks Plugin

  1. Download AppLinks, along with its dependencies, as a simple zip archive from the Atlassian repository.
  2. Unzip the archive into a location of your choice.

(info) The AppLinks archive includes the Atlassian Shared Access Layer (SAL) JARs.

Step 3. Install AppLinks in JIRA

(warning) Refer to the compatibility matrix above.

Follow these steps if you want to install AppLinks into JIRA 3.13.5:

  1. Stop your JIRA server.
  2. Copy the following JARs into JIRA's installation directory at <Installation Directory>/atlassian-jira/WEB-INF/lib:
    • applinks-api-x.x.x.jar
    • applinks-core-x.x.x.jar
    • applinks-legacyjira-plugin-x.x.x.jar
    • applinks-jira-common-x.x.x.jar
    • sal-api-x.x.x.jar
    • sal-core-x.x.x.jar
    • sal-legacyjira-plugin-x.x.x.jar
    • sal-spring-x.x.x.jar
  3. Restart JIRA.

Follow these steps if you want to install AppLinks into JIRA 4.0.x:

  1. Stop your JIRA server.
  2. Copy the following JAR into your {JIRA_HOME}/plugins/installed-plugins directory.
    • applinks-jira-plugin-x.x.x.jar
  3. Restart JIRA.

(info) The Shared Access Layer (SAL) is bundled with JIRA 4, so there's no need to install it.

Step 4. Install AppLinks in Confluence

Follow these steps if you want to install AppLinks into Confluence:

  1. In Confluence's Administration Console, click 'Plugins' then browse for and upload the following JAR:
    • applinks-confluence-plugin-x.x.x.jar
  2. The AppLinks plugin should appear in the list of installed plugins. If not, restart Confluence.

(info) The Shared Access Layer (SAL) is bundled with Confluence, so there's no need to install it.

Step 5. Install AppLinks in FishEye and Crucible

Follow these steps if you want to install AppLinks into FishEye and/or Crucible:

  1. Copy the following JAR into FishEye's installation directory at FISHEYE_INST/var/plugins/user:
    • applinks-fisheye-plugin-x.x.x.jar
  2. In the FishEye Admin screens, click 'Plugins' then 'Check for new plugins in FISHEYE_INST/var/plugins/user'. The AppLinks plugin should appear in the list of installed plugins. If not, restart FishEye.

(info) The Shared Access Layer (SAL) is bundled with FishEye/Crucible, so there's no need to install it.

Now you will need to configure the linked applications using the administration screens of each application. Please refer to the administration guide.

RELATED TOPICS

Application Links Administration Guide
Application Links Documentation Home
Atlassian Product Integration

  • No labels

5 Comments

  1. Hello,

    where can we watch the evolution of the work on the release of version 3.0 of Applinks.

    Regards.

  2. Hi,

    This is Luke from Korean partner, Goldpitcher.
    One of our customer wanted to use this Application Link on JIRA 4.12.

    But we confirmed that Application Link 2.1.2 and 2.5 rc1, rc2 all doesn't work under JIRA 4.1.2.

    Is there any way to use it under 4.1.x version ?

    Cheers,
    Luke

    1. Anonymous

      Were you able to get Application Links working in JIRA 4.1.2?  I am having the same problem.

  3. Anonymous

    Any updates on the Atlassian-authored AppLinks plugin?

    Could really use it

  4. Hi,

    The Application Links (v3.0) plugin is bundled with FishEye 2.4 and will be bundled with Confluence 3.5 and JIRA 4.3. You cannot download it separately, as the application links plugin will not be compatible with other versions of our products. The latest Application Links documentation is available here: Application Links documentation

    Please note, you can still set up an application link from a FishEye 2.4 instance (with the plugin) to a Confluence or JIRA instance (without the plugin), as described on Adding an Application Link in the latest documentation.

    You can also set up links without the plugin at all using the Basic HTTP, Trusted Apps and OAuth authentication protocols used by many of our products. However, this will require more manual configuration. Please see the administrator's documentation for the relevant product, for instructions on how to configure these protocols.

    Kind Regards,
    Andrew

Anonymous

You are not logged in. Any changes you make will be marked as anonymous. You may want to Log In if you already have an account. You can also Sign Up for a new account.