All Versions

   Bamboo 5.0.x
   Bamboo 4.4.x
   Bamboo 4.3.x
   Bamboo 4.2.x  
   More... 

Bamboo 2.3 Documentation

Index
Downloads (PDF, HTML & XML formats)

This documentation relates to an earlier version of Bamboo.
View this page in the current documentation or visit the current documentation home.

Skip to end of metadata
Go to start of metadata

Requirements

  1. JDK/JRE 1.5+. We strongly recommend that you use Sun JDK 1.5 (Java 5) and above to run your Bamboo installation. You are likely to experience incompatibility problems running Bamboo under a different JDK and ensure that there are no other JDK's in your PATH.
    (tick) Don't forget to point your JAVA_HOME system environment variable to your Sun JDK before installing Bamboo, as Bamboo will automatically configure JDK capabilities based on the system environment variables on your machine.
  2. A database. NOTE: Bamboo ships with a built-in HSQL database, which is fine for evaulation purposes. For production environments it is recommended that you use an enterprise database, as described in Connecting Bamboo to an external database.
  3. Only if you are using the Bamboo EAR-WAR distribution: A servlet container that supports Servlet 2.4 specification. Most modern containers should comply to this.
Icon

While some of our customers run Bamboo on SPARC-based hardware, Atlassian only officially supports Bamboo running on x86 hardware and 64-bit derivatives of x86 hardware.

Choose your Bamboo 'Distribution':

Bamboo is available in two 'distributions':

Standalone distribution
  • Pre-packaged with the Jetty application server
  • Requires virtually no setup
  • Recommended for all users
EAR-WAR distribution
  • Deploys into an existing application server
  • Requires manual configuration
  • Suitable only for system administrators

The Standalone distribution is recommended even for organisations with an existing application server environment.

NEXT


RELATED TOPICS

Running the Setup Wizard

Upgrade Guide
Release Notes

Bamboo Documentation