All Versions

   Bamboo 5.0.x
   Bamboo 4.4.x
   Bamboo 4.3.x
   Bamboo 4.2.x  
   More... 

Bamboo 2.6 Documentation

Index
Downloads (PDF, HTML & XML formats)

This documentation relates to an earlier version of Bamboo.
View this page in the current documentation or visit the current documentation home.

Skip to end of metadata
Go to start of metadata

On this page:

1. Check the System Requirements

 

Supported Platforms

Please read the Supported Platforms page before you install Bamboo. The Supported Platforms page lists the applications servers, databases, operating systems, web browsers and JDKs that we have tested Bamboo with and recommend.

Hardware Requirements

While some of our customers run Bamboo on SPARC-based hardware, Atlassian only officially supports Bamboo running on x86 hardware and 64-bit derivatives of x86 hardware.

Servlet Container Requirements

If you are using the Bamboo EAR-WAR distribution, you will need a servlet container that supports the Servlet 2.4 specification. Most modern containers should comply to this.

2. Choose your Bamboo 'Distribution':

 

Bamboo is available in two 'distributions' — Standalone or EAR-WAR. The Standalone distribution is recommended (even for organisations with an existing application server environment).

Standalone Distribution

  • Pre-packaged with the Jetty application server
  • Requires virtually no setup
  • Recommended for all users

EAR-WAR Distribution

  • Deploys into an existing application server
  • Requires manual configuration
  • Suitable only for system administrators

3. Next Steps

Related Topics