Bamboo failing to display JUnit tests correctly

Platform Notice: Data Center Only - This article only applies to Atlassian products on the Data Center platform.

Note that this KB was created for the Data Center version of the product. Data Center KBs for non-Data-Center-specific features may also work for Server versions of the product, however they have not been tested. Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.

*Except Fisheye and Crucible

Symptoms

Junit results aren't being read/displayed by Bamboo.

AND

You may find the following errors in the logs,

1 java.io.IOException: Lock obtain timed out:

OR,

1 2 3 4 5 6 7 8 9 10 11 12 13 Stack Trace: Method public com.atlassian.bamboo.resultsummary.BuildResultsSummary com.atlassian.bamboo.build.BuildResultsAction.getFailingSinceForTest(com.atlassian.bamboo.results.BuildResults,com.atlassian.bamboo.results.tests.TestResults) throws java.io.IOException threw an exception when invoked on com.atlassian.bamboo.build.ViewBuildResults@22942d The problematic instruction: ---------- ==> assignment: failingSinceBuild=action.getFailingSinceForTest(buildResult, testResult) [on line 263, column 21 in lib/components.ftl] in user-directive cp.displayUnitTestsSummary [on line 181, column 17 in viewBuildResults.ftl] ---------- Java backtrace for programmers: ---------- freemarker.template.TemplateModelException: Method public com.atlassian.bamboo.resultsummary.BuildResultsSummary com.atlassian.bamboo.build.BuildResultsAction.getFailingSinceForTest(com.atlassian.bamboo.results.BuildResults,com.atlassian.bamboo.results.tests.TestResults) throws java.io.IOException threw an exception when invoked on com.atlassian.bamboo.build.ViewBuildResults@22942d at freemarker.ext.beans.SimpleMethodModel.exec(SimpleMethodModel.java:136)

Cause

Bamboo was not shutdown properly, as a result the Lucene lock files were not cleaned up from the <Bamboo-Home>/index directory

Resolution

To fix this issue,

  1. Delete the lock files from the <Bamboo-home>/index directory.

  2. Restart Bamboo.

Note, you may need to perform a full re-index of Bamboo from, Administration -> reindexing if you notice that build telemetry is inconsistent.

Updated on April 8, 2025

Still need help?

The Atlassian Community is here for you.