App not visible in Find New Apps in Bamboo
Platform Notice: Data Center Only - This article only applies to Atlassian products on the Data Center platform.
Note that this KB was created for the Data Center version of the product. Data Center KBs for non-Data-Center-specific features may also work for Server versions of the product, however they have not been tested. Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.
*Except Fisheye and Crucible
Summary
A third-party app is not showing up on the Find new apps page in Bamboo, thus the plugin can't be installed.
Diagnosis
When going to the Cogicon > Manage apps > Find new apps and searching for an existing plugin, it is not retrieved and cannot be installed directly through the UI.
A message "No apps matching your search criteria are available for installation in your Bamboo instance " appears.
Cause
Apps that do not officially support the Bamboo version you're running are not retrieved on the Find new apps page.
Solution
Install the app manually:
Find the plugin on Marketplace and open its page.
Go to the Versions tab and open See all versions.
Either download the JAR from the most recent version or copy the URL from the Download button.
On Bamboo, click the Cog icon > Manage apps > Upload app.
On the pop-up, either select the downloaded JAR file or paste the download URL you've copied.
Hit Upload.
The app should then be installed. You'll see that it gets marked asIncompatible. This is because theplugin vendorhas yet to update their app to be officially compatible with this version of Bamboo (and newer ones).
This also means that the pluginmightormight not work properlyand that itsfunctionalities and features might be limited. However, there's also a chance that it'll work just fine, but you'd have to test it further to know that.
If you see any issues with the app itself and its functionalities due to the unsupported version, please reach out to the plugin developer. Contact information is available on the plugin's Marketplace page, in the Support tab.
The UI will also show you a Request update option to let the plugin vendor know you'd like their app to be compatible with your current version of Bamboo.
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