The Atlassian Marketplace server is not reachable
Symptoms
When going to manage/add new add-ons page, this error is displayed:
The Atlassian Marketplace server is not reachable. To avoid problems when loading this page, you can disable the connection to the Marketplace server
The Bamboo logs contain the following errors:
# Please, refer to "Resolution 1"
2015-02-11 14:26:28,892 WARN [http-bio-8085-exec-12] [AsynchronousTaskManager] Configured application base URL (http://192.168.2.135:8085/bamboo) does not match base URL from request (http://192.168.2.135:8085)
# Please, refer to "Resolution 2"
2013-10-29 14:30:17,194 WARN [http-bio-7990-exec-5] user 870x497x1 1lzkc13 XXX.XXX.XXX.XXX,127.0.0.1 "GET /plugins/servlet/upm/marketplace HTTP/1.0" com.atlassian.upm.pac.PacClientImpl Error when querying application info from MPAC: com.atlassian.marketplace.client.MpacException: javax.net.ssl.SSLPeerUnverifiedException: peer not authenticated
Resolution 1
Please, update Bamboo's base URL under "Bamboo administration >> System >> General configuration >> Base URL"
Cause
The Atlassian Marketplace needs to verify the SSL connection between Bamboo and itself. This occurs because the certificate is missing or has been tampered with by the local Proxy.
Resolution 2
Default Password
Please see the following question on Atlassian Answers and Problems Connecting to the Atlassian Marketplace for more information.