Email change is not reflected in Atlassian Cloud

Summary

The email address of an Active Directory user was modified, the changes are not reflected in Atlassian Cloud after several hours

Environment

  • Affected product: Atlassian Guard

  • Azure Active Directory (Entra ID)

  • Atlassian Cloud Enterprise Application

  • SCIM provisioning

Diagnosis

The user email was modified in AD, since the organization uses SCIM provisioning, the changes should be propagated to Atlassian Cloud, however the email on the Atlassian Account remains outdated

Cause

There are a couple possibilities:

  • There is another Atlassian Account using the new email already
  • There is a conflict SCIM record with stale information

Solution

Check your Managed Accounts to find the other account that is already associated to the new email, if the account is not linked to your Identity Provider you can modify it by adding a "free_" string at the beginning of the email, for example if the email is email@domain.com you can change this to free_email@domain.com. This will allow your SCIM integration to update the original Atlassian Account email that was not taking place originally. 

If this other account with the new email is also linked to your Identity Provider you can reach out to Atlassian Support and provide the following information from the Active Directory account that is not getting updated with the new email:

  • ObjectID

  • UPN

  • Old email

  • New email

The support team will assist you identify why the Atlassian Account email is not getting updated. 





Last modified on Jun 11, 2024

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