This documentation relates to an earlier version of Confluence.
View this page in the current documentation or visit the current documentation home.

Skip to end of metadata
Go to start of metadata

Confluence is a 'web application', meaning it runs centrally on a server and users interact with it through web browsers from any computer. Hence, Confluence requires hardware and some additional software in order to operate. The software platforms currently supported for Confluence are listed on the Supported Platforms page. However, more detailed information regarding Confluence's software and hardware requirements can be found on this page. This page also covers information about:

  • Platforms which Atlassian does not support, but should work with Confluence
  • Platforms and other software that are incompatible with Confluence or have known problems running in conjunction with Confluence.

On this page:

Introduction

Confluence works with a broad range of operating systems, database systems and application servers. Provided you have the technical knowledge, it is very likely that you will be able to run Confluence with an 8-year-old database or even on some 8-year-old hardware. Realistically, it is not technically feasible for us to provide our legendary support service on all environments available. There can only be a finite number of platforms and release versions of those that we support.

Our rule of thumb when releasing a new version of Confluence is that we will officially support platforms that have been released within the last one to two years (or the latest version of that platform if no new version of it was released in that period). This does not necessarily mean that you will need to upgrade your database or application server every time you upgrade Confluence. However, if you do run into problems with an unsupported version of a database or application server, we may have to ask you to upgrade to something newer.

For example, you are running Confluence 2.7.3 with PostgreSQL 8.0 and everything works fine. You decide to upgrade to Confluence 2.8, which only supports version 8.1 of PostgreSQL. The chances are that you can run Confluence 2.8 with PostgreSQL 8.0 with no problems whatsoever. However, if you do run into problems, we may ask you to upgrade to PostgreSQL 8.1 or 8.2 before we dive deeper into the problem and provide further assistance.

Please refer to our Supported Platforms topic for details on platforms that we currently support in this version of Confluence and our Supported Platforms FAQ topic for details on our support handling procedures.

Atlassian's Hosted Solutions are an Alternative

If you do not have the resources to set up and maintain a Confluence installation locally, how about using one of our hosted solutions instead? We can run and maintain your own installation of Confluence on one of our servers and we will handle all the testing, monitoring and upgrading processes for you. For more information, please refer to our Confluence Hosted and our integrated JIRA Studio solutions on our website.

Confluence Software Requirements

Please read the Supported Platforms page for Confluence. This page contains important information about all client and server software requirements, which are supported for Confluence 3.4.x.

Client Software Requirements

Please read the following additional information regarding client software requirements for Confluence.

Web Browsers

Icon

Internet Explorer 6, Mozilla Firefox 2 and Safari 2 will no longer be supported in future versions of Confluence. Please read our End of Support Announcements for Confluence.

Server Software Requirements

Please read the following additional information regarding server software requirements for Confluence.

Java

You will need to install a Java Development Kit (JDK) on your operating system before before proceeding with a Confluence installation. For instructions on installing the Sun JDK for Windows and Linux/UNIX, please refer to Installing Sun JDK for Confluence.

Important notes about installing a JDK for Confluence

Icon
  • Confluence requires the full installation of a JDK. It is not enough to run Confluence on a Java Runtime Environment (JRE) alone.
  • While JDK 1.5 is fine, JDK 6 (1.6) is the preferred platform as it is faster and more reliable. Please refer to our End of Support Announcements for Confluence.

We do not provide support for non-Sun JDKs. However, if you wish to install a non-Sun JDK and you want to use SSL, you will also need to install the Sun JSSE package.

OpenJDK is currently not supported. A JIRA issue to request support for this JDK has been created (CONF-16431).

Operating Systems

If you would like to run Confluence on VMware, please read our Running Confluence in a Virtualised Environment document first.

Confluence on Virtualised Environments

Icon


Atlassian officially supports non-clustered installations of Confluence 3.0 and later on VMware. Although possible, we do not recommend (nor support) running versions of Confluence prior to 3.0 on VMware, since Confluence 3.0 resolved many performance issues that were present in earlier versions. Be aware that we also do not support clustered installations of Confluence on VMware. Please comment or vote on the feature request at CONF-19559.

Application Servers

Atlassian supports the application servers listed on the Supported Platforms page, provided they are running on Windows, Linux, a UNIX-based operating system (such as NetBSD, FreeBSD, OpenBSD and Solaris) or Mac OS X.

If you have no preference for a particular application server and wish to set up Confluence for production purposes, we highly recommend installing Confluence Standalone, which includes the Apache Tomcat application server.

Confluence 3.4.x supports the application server versions listed below. We may ask you to migrate to one of the supported application servers before we can provide you with further support.

  • Apache Tomcat — 5.5.20 to 6.0

Databases

Atlassian supports the databases listed on the Supported Platforms page, provided they are running on Windows, Linux, a UNIX-based operating system (such as NetBSD, FreeBSD, OpenBSD and Solaris) or Mac OS X.

If you have no preference for a particular database and wish to set up Confluence for production purposes, we highly recommend using PostgreSQL. This is a scalable, robust and free database server that is also easy to set up. For database setup information, please refer to Database Setup For Any External Database.

We assume that Confluence 3.4.x works fine with the database versions listed below. However, we do not test these versions regularly and we may ask you to migrate to one of the supported databases before we can provide you with further support.

  • PostgreSQL — 8.0, 8.3
  • MySQL — 5.0 - 5.0.28 (using the InnoDB storage engine, not MyISAM)
  • Oracle — 11

Antivirus Software Configuration

The presence of antivirus software on your operating system running Confluence greatly decreases the performance of Confluence. Antivirus software that intercepts access to the hard disk is particularly detrimental and may even cause errors in Confluence.

You should configure your antivirus software to ignore the following directories:

  • Confluence home directory
  • Confluence's index directory
  • All database-related directories

(warning) This recommendation above is particularly important if you are running Confluence on Windows. No matter how fast your hardware is, antivirus software will almost always have a negative impact on Confluence's performance and may render Confluence impossible to use.

Confluence Hardware Requirements

Please be aware that while some of our customers run Confluence on SPARC-based hardware, Atlassian only officially supports Confluence running on x86 hardware and 64-bit derivatives of x86 hardware.

Server Load

Server load depends primarily on the number of users online at once and their usage of Confluence.

Under 25 concurrent users:

  • 2GHz+ CPU or equivalent
  • 512MB RAM

Over 25 concurrent users:

  • Dual 2GHz+ CPU Xeon or equivalent
  • 2GB RAM

Over 100 concurrent users:

  • Quad 2GHz+ CPU Xeon or equivalent
  • 4GB of RAM

See Server Hardware Requirements Guide for details.

Refer also to the tips on reducing out of memory errors, in particular the section on Permanent Generation Size.

Disk Space

Confluence Install Directory - 250MB

  • Install files
  • Nightly site backups
  • Temporary files

Confluence Home Directory or External Database - 250MB minimum

  • Text content
  • File attachments
RELATED TOPICS

End of Support Announcements for Confluence
Confluence Installation Guide
Confluence Setup Guide
Installing Confluence Standalone Using the Windows Evaluation Installer
Installing the Confluence EAR-WAR Edition
Confluence Cluster Installation
Example Size and Hardware Specifications From Customer Survey
Installing Confluence and JIRA Together
Confluence Documentation Home
Server Hardware Requirements Guide
Supported Platforms FAQ