Atlassian Companion app can't be opened in MacOS Catalina
This article applies to Confluence Server and Data Center 6.11 and later.
Problem
Confluence Server and Data Center users are unable to edit attached files using the Atlassian Companion app. Companion app fails to open with the following error:
"Atlassian Companion.app" can't be opened because Apple cannot check it for malicious software.
This software needs to be updated. Contact the developer for more information.
Cause
Some versions of MacOS, such as 10.5 (Catalina), prevent you from opening any apps built after a specific date that have not been notarized by Apple. This is to protect you from malicious software.
Earlier versions of the Companion app were not yet notarized.
Possible Resolution
Upgrade Companion App to the latest version (currently 1.3.1).
Workaround
If you can't yet upgrade or the issue still persists after the upgrade, as a workaround, you can go to System Preferences > Security & Privacy > General. The Atlassian Companion app should be listed as blocked. Choose Open anyway.
See the "How to open an app that hasn’t been notarized or is from an unidentified developer" section of Safely open apps on your Mac in the Apple documentation for more information.