Creating a space does not work
Platform Notice: Cloud - This article applies to Atlassian products on the cloud platform.
Summary
Upon tapping the Create button to create a space, the space is not created and no messages are displayed.
Cause
This behavior is triggered if the space being created has the same space key from a restricted space (in which the user creating it is not able to see). To have a clear message at the UI, the following suggestion has been created:
Solution
To confirm if that is the scenario and change the space key during the creation of the space, a site admin can be contacted in order to access the Space permissions under Confluence's administration and filter the search by the key: