Custom emojis are not displayed as expected in Confluence page
Platform Notice: Cloud - This article applies to Atlassian products on the cloud platform.
Summary
Confluence Cloud users are able to add and use custom emojis on Confluence pages. After a custom emoji is uploaded, it becomes available for users to use on Confluence pages.
After some time, they suddenly realize that the emoji has been replaced with text, specifically the name of the emoji, surrounded by colons (:
), e.g. :test-emoji:
When the emoji was created.
When the emoji is not rendered correctly.
Site administrators can manage and delete custom emojis using https://<yourDomain>.atlassian.net/admin/emoji
Diagnosis
- Add the custom emoji (e.g.
:test-emoji:
) to a new test page and publish the page. - Next, compare the storage format of this newly published page with that of an existing page that already contains the affected custom emoji (e.g.
:test-emoji:
) on it. Notice different
emoji-id
shown in the two storage formats.Original page's storage format... <ac:emoticon ac:name="test-emoji" ac:emoji-shortname=":test-emoji:" ac:emoji-id="abc123" ac:emoji-fallback=":test-emoji:" /> ...
Newly published page's storage format... <ac:emoticon ac:name="test-emoji" ac:emoji-shortname=":test-emoji:" ac:emoji-id="xyz789" ac:emoji-fallback=":test-emoji:" /> ...
Cause
This occurs when an administrator removes a custom emoji from the URL https://<yourDomain>.atlassian.net/admin/emoji.
After deletion, the default name that was used to save the emoji is displayed. If a user uploads the same emoji again using the same name, the pages will not display correctly because each emoji is assigned a unique emoji-id, and the previous emoji-id will no longer have associated data following the deletion.
Solution
- Edit the page and remove the old text associated with the emoji.
- Re-upload the emoji with old name or a new name
- Insert the emoji back into the desired location on the page and save the page.