Error Submitting a Support Request via the Support Tools Plugin

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Symptoms

  1. The UI shows an error that begins with "An error occurred while creating your support request email:"
  2. The following appears in the atlassian-confluence.log:
2012-07-16 19:04:11,199 ERROR [http-8080-8] [support.tools.action.SupportToolsAction] execute 
Error creating or sending your support request:
 -- url: /plugins/servlet/stp/view/create-support-request/execute | userName: admin | referer: 
http://localhost:8090/plugins/servlet/stp/view/
java.lang.ClassCastException: java.util.ArrayList cannot be cast to 
com.atlassian.support.tools.properties.PropertyStore
at com.atlassian.support.tools.salext.AbstractSupportApplicationInfo.loadStore(AbstractSupportApplicationInfo.java:427)
at com.atlassian.support.tools.salext.AbstractSupportApplicationInfo.saveProperties(AbstractSupportApplicationInfo.java:397)
at com.atlassian.support.tools.salext.mail.AbstractMailUtility.sendSupportRequestMail(AbstractMailUtility.java:30)

Cause

This is caused by a known bug in the Support Tools Plugin and is being tracked in STP-158.

Resolution

The bug is fixed in version 3.0.8 of the STP plugin, so visit the Confluence Admin >> Manage Plugins page and update the Support Tools Plugin, which is located under the System Plugins section.

Last modified on Mar 30, 2016

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