Missing Timezone When Attempting To Create a Team Calendars for Confluence
Platform Notice: Data Center Only - This article only applies to Atlassian products on the Data Center platform.
Note that this KB was created for the Data Center version of the product. Data Center KBs for non-Data-Center-specific features may also work for Server versions of the product, however they have not been tested. Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.
*Except Fisheye and Crucible
Summary
Problem
Quite a number of timezone disappears from the timezone drop down menu (the Create Calendar dialog box):

For the example above, it only shows timezones from America and Africa
Diagnosis
Diagnostic Steps
Make sure that you try this on multiple browsers to make sure it is not a client-side issue
Try to enter safe mode, in
Confluence Admin >> Manage Add-Ons
, and enable only Team Calendars for Confluence
Cause
Cause unknown, though it may most likely be due to corrupted caches
Solution
Resolution
Restarting Confluence seems to resolve the issue completely. You can also try to simply flush all the caches in Confluence Admin >> Cache Statistics
.
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