Slow Page Publishing Due to Antivirus Extension in Browser
Platform Notice: Cloud, Server, and Data Center - This article applies equally to all platforms.
Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.
*Except Fisheye and Crucible
Problem
- Saving/publishing Confluence pages appear to be slow in some browsers and not others (for example, slow in Chrome, but normal in Firefox and Internet Explorer).
- The browser's HAR file shows that, in specific browsers only, some requests are taking a very long time to receive a response. In the example below, some requests were waiting 4-13 seconds:
- Nothing unusual appears in Tomcat or Confluence logs server-side to suggest that the application is slow to process the request, even when Page Request Profiling is enabled.
Cause
Check your browser for browser-specific extensions, such as ones from Symantec or Norton. Such extensions may be intercepting requests for analysis before forwarding them to/from the server, causing a preceived delay to the user.
Resolution
Work with your IT systems administrators to resolve this issue, which may involve:
Disabling the browser extension
White-listing Confluence-specific URLs in the extension's configurations
- Using another browser