Team Calendars for Confluence displays 500 Error When using Export to iCalendar

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Symptoms

When using Team Calendars for Confluence built in function to Export to iCalendar, the export fails and a 500 Server Error is Displayed in the browser.

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Cause
Stack Trace:hide
Referer URL https://xxxxxxx/calendar/mycalendar.action

 

The following appears in the atlassian-confluence.log:

2014-08-05 12:55:34,550 ERROR [http-8090-106] [common.error.jersey.ThrowableExceptionMapper] toResponse Uncaught exception thrown by REST service
– url: /rest/calendar-services/1.0/calendar/export/subcalendar/private/xxxxxxxxxxxxxx.ics | userName: <username>
javax.ws.rs.WebApplicationException: java.lang.NullPointerException

Cause

This issue normally occurs when an interruption of read and write permissions in the cache folder happens due to a connection issue or performance.

Workaround

Clearing the Plugins Cache will resolve this issue. You can clear the cache, by doing the following:

  1. Shutdown Confluence
  2. Ensure the user running Confluence has full read/write privileges to the confluence-home directory.
  3. Remove the following directories
    (warning) This will remove the plugin cache files only and will not permanently remove any plugins. These directories will be recreated during the next Confluence startup.  However, some third-party plugins may store metadata in these directories, so we recommend creating a temporary backup of the directories.
    • <confluence-home>/bundled-plugins
    • <confluence-home>/plugins-cache
    • <confluence-home>/plugins-osgi-cache
    • <confluence-home>/plugins-temp
    • <confluence-home>/bundled-plugins_language
  4. Start Confluence

Last modified on Mar 30, 2016

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