Unable to Enable Team Calendars for Confluence after Upgrading Plugin to Version 2.5.0 or Higher

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Symptoms

After upgrading the Team Calendars for Confluence to version 2.5.0, the plugin fails to enable, with this error message after any attempts to enable the plugin: This plugin failed to enable. Your license may be invalid. Please refer to the logs for more information.  The following appears in the atlassian-confluence.log:

 2012-10-05 17:52:44,643 ERROR [Spring executor 25] [plugin.osgi.factory.OsgiPlugin] onSpringContextFailed Unable to start the Spring context for plugin com.atlassian.confluence.extra.team-calendars
 -- referer: http://localhost:8420/c42/plugins/servlet/upm | url: /c42/rest/plugins/1.0/ | userName: admin
org.springframework.beans.factory.BeanCreationException: Error creating bean with name 'myWorkIntegration' defined in URL [bundle://130.0:0/META-INF/spring/spring-components.xml]: Invocation of init method failed; nested exception is java.lang.ClassCastException: com.atlassian.upm.license.internal.event.PluginLicenseEventPublisherImpl cannot be cast to com.atlassian.upm.api.license.PluginLicenseEventRegistry
    at org.springframework.beans.factory.support.AbstractAutowireCapableBeanFactory.initializeBean(AbstractAutowireCapableBeanFactory.java:1338)
    at org.springframework.beans.factory.support.AbstractAutowireCapableBeanFactory.doCreateBean(AbstractAutowireCapableBeanFactory.java:473)
    at org.springframework.beans.factory.support.AbstractAutowireCapableBeanFactory$1.run(AbstractAutowireCapableBeanFactory.java:409)
....
Caused by: java.lang.ClassCastException: com.atlassian.upm.license.internal.event.PluginLicenseEventPublisherImpl cannot be cast to com.atlassian.upm.api.license.PluginLicenseEventRegistry
...

Cause

Corrupted plugin cache.

Resolution

Update the plugin manager (Confluence Admin >> Plugins >> Update - the blue bar notification that requests you to update your plugin manager) and update all outdated plugins. Then clear the plugin cache by doing the following:

  1. Shutdown Confluence
  2. Ensure the user running Confluence has full read/write privileges to the confluence-home directory.
  3. Remove the following directories
    (warning) This will remove the plugin cache files only and will not permanently remove any plugins. These directories will be recreated during the next Confluence startup.  However, some third-party plugins may store metadata in these directories, so we recommend creating a temporary backup of the directories.
    • <confluence-home>/bundled-plugins
    • <confluence-home>/plugins-cache
    • <confluence-home>/plugins-osgi-cache
    • <confluence-home>/plugins-temp
    • <confluence-home>/bundled-plugins_language
  4. Start Confluence
 

After that, restart Confluence, and try to either enable or install the Team Calendars for Confluence 2.5.0 or higher again.

Last modified on Feb 26, 2016

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