Unable to Receive Email Notifications From Confluence

Still need help?

The Atlassian Community is here for you.

Ask the community

Symptoms

  1. Email updates are not sent from Confluence

Diagnosis

  1. No error message is logged in Confluence
  2. In addition, test send email failed to your company domain. However test send email works to other domains, eg. gmail, hotmail, other than your company domain.

Cause

Some mail servers may be configured to attempt verification of the sender address before accepting. Mail logs look like:


Jan 26 20:16:46 8291bef994055f31ab2945185c533548 postfix/smtp[23126]: E1CD7A62AA: to=<yourUserName@yourCorporateDomain.com>, relay=mail.yourCorporateDomain.com[<IP Address>]:25, delay=7966, delays=7964/0.01/0.73/0.96, dsn=4.1.7, status=deferred (host mail.yourCorporateDomain.com[<IP address>] said: 450 4.1.7 <yourUserName@yourCorporateDomain.com>: Sender address rejected: unverified address: connect to yourCorporateDomain [<IP Address>]: Connection timed out (in reply to RCPT TO command))

Resolution

Whitelist the email address used by Confluence so that it trusts messages from that address rather than attempting to verify its validity.


Last modified on Mar 30, 2016

Was this helpful?

Yes
No
Provide feedback about this article
Powered by Confluence and Scroll Viewport.