Unable to edit files in office due to SSL not being enabled

Still need help?

The Atlassian Community is here for you.

Ask the community

Symptoms

A error message appears when you try to edit an office file and confluence is not using SSL.

"Access to this web server is disabled by default because it is controlled by basic authentication and does not use Secure Socket Layer (SSL)."

 

Cause

According to the official Microsoft KB:

Quote

This problem occurs when the following conditions are true:

  • The server is configured for Basic authentication.
  • The connection between your computer and the web server does not use Secure Sockets Layer (SSL).

By default, file operations that use Basic authentication over a non-SSL HTTP connection are disabled in Office 2010 and Office 2013 applications.

When Basic authentication is disabled, one of the following events occurs:

  • The client application uses a different authentication method. This occurs if the server supports a different authentication method.
  • The request fails (for details about what happens when a request fails, see the list in the "Additional symptom details" section).

Resolution

You have two options to fix the issue:

1) Enable SSL in confluence.

2) Disable basic authentication on the client computer. More info about this can be found in the Microsoft KB.

Last modified on Nov 2, 2018

Was this helpful?

Yes
No
Provide feedback about this article
Powered by Confluence and Scroll Viewport.