Unable to save new license with 'The license you entered is not a valid cluster license' error due to removed files from installation directory

Still need help?

The Atlassian Community is here for you.

Ask the community

Symptoms

When saving a new license key with a higher or lower user tier, the error 'The license you entered is not a valid cluster license' is shown. However, the instance is not deployed in a clustered environment.

The following appears in the atlassian-confluence.log:

2014-01-29 23:55:09,227 WARN [TP-Processor9] [atlassian.plugin.webresource.DefaultResourceDependencyResolver] resolveDependencies Cannot find web resource module for: com.atlassian.analytics.analytics-client:js-events
 -- url: /plugins/servlet/notifications-miniview | userName: admin | referer: https://localhost:8090/admin/doupdatelicense.action

Cause

Some required files were removed from the Confluence Installation Directory.

Resolution

  • Restore any of the missing files (from the following) to the installation directory:
    • META-INF/maven/com.atlassian.confluence/confluence-webapp/pom.properties
    • WEB-INF/lib/xwork-1.0.3.4.jar
    • META-INF/maven/com.atlassian.confluence/confluence-webapp/pom.xml
    • WEB-INF/lib/confluence-cache-ehcache-4.3.7.jar

Last modified on Mar 30, 2016

Was this helpful?

Yes
No
Provide feedback about this article
Powered by Confluence and Scroll Viewport.