User Getting Logged Out Intermittently Due to the Groupname Case Change in LDAP
Platform notice: Server and Data Center only. This article only applies to Atlassian products on the Server and Data Center platforms.
Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.
*Except Fisheye and Crucible
Problem
- User session, JSESSIONID is being refreshed from the browser cookies.
- Intermittent permission access loss - user cannot view page intermittently due to insufficient permission.
The following appears in the
atlassian-confluence.log.
2015-06-08 04:07:55,679 WARN [scheduler_Worker-10] [atlassian.crowd.directory.DbCachingRemoteChangeOperations] findGroupsToUpdate remote group name [ Sample Group ] casing differs from local group name [ sample group ]. Group details will be kept updated, but the group name cannot be updated
Diagnosis
Diagnostic Steps
- Perform a full synchronization on LDAP user directory.
- Check with the log file.
Cause
User is removed from a particular group (which has a certain permission) when a user directory synchronization is executed.
Workaround
- Revert the character case (of the LDAP Group Name) back to the original ones.
- In this example,
Sample Group
should change back tosample group
. - Perform another full synchronization on LDAP user directory and check if there is any errors from
atlassian-confluence.log
.