User appears not to receive any mail notification

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Symptoms

  1. Only a single user did not received any mail notification at all
  2. Other users in the organization able to receive mail notification
  3. No errors printed in both atlassian-confluence.log & catalina.log
  4. Checked the Spam Inbox and the mails were not there

Diagnosis

Enable mail debug logging as follows:

  1. Stop Confluence.
  2. Enable mail debug logging by including -Dmail.debug=true parameter to CATALINA_OPTS. See Configuring System Properties. This parameter will print out logging email protocol details in catalina.log

    1. If you do not see the details in the catalina.out log, try removing any spaces that may be present with the parameter

  3. Restart Confluence.
  4. Send test mail to the affected user's mail address. The result would be something like below (printed inside catalina.log):

    DEBUG SMTP: trying to connect to host "smtp.xchange.com", port 25, isSSL false
    220 smtp.xchange.com ESMTP Service (Lotus Domino Release 8.5.3) ready at Wed, 7 Mar 2012 04:33:02 -0500
    DEBUG SMTP: connected to host "smtp.schange.com", port: 25
    
    EHLO SEACONFLUENCE
    250-smtp.xchange.com Hello SEACONFLUENCE ([192.168.39.119]), pleased to meet you
    250-HELP
    250-SIZE
    250 PIPELINING
    DEBUG SMTP: Found extension "HELP", arg ""
    DEBUG SMTP: Found extension "SIZE", arg ""
    DEBUG SMTP: Found extension "PIPELINING", arg ""
    DEBUG SMTP: use8bit false
    MAIL FROM:<Confluence>
    250 Confluence... Sender OK
    RCPT TO:<hanis@xchange.com>
    250 hanis@xchange.com... Recipient OK
    DEBUG SMTP: Verified Addresses
    DEBUG SMTP:   hanis@xchange.com
    DATA
    354 Enter message, end with "." on a line by itself
    Date: Wed, 7 Mar 2012 04:33:02 -0500 (EST)
    From: Confluence
    To: hanis@xchange.com
    Message-ID: <16388685.1814.1331112782674.JavaMail.SEACONFLUENCE$@SEACONFLUENCE>
    Subject: [confluence] Core Services > Manila Status Report
    MIME-Version: 1.0
    Content-Type: text/html; charset=UTF-8
    Content-Transfer-Encoding: 7bit
    Precedence: bulk
    Auto-Submitted: auto-generated
  5. Note that this part of transaction was reported as successful by Confluence, hence, it is up to the SMTP server to perform the rest of the transaction.

Cause

Customer is using Lotus Domino as seen above. It turns out that Confluence mails were successfully sent out to the user but they went to a folder that was hidden. 

Resolution

Check for any hidden folders which stores the mail notification received from Confluence.

 

 

 

 

 

 

 

 

 

 

 

 

Last modified on Nov 2, 2018

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