Confluence Question Top Menu Button Missing after Upgrade

Symptoms

After upgrading the Confluence Questions plugin, the top menu button is missing and the number of modules will reduce to less than 100 (this plugin has more than 100 modules), when browsing to Confluence Admin > Manage add ons > Confluence Questions Plugin.


Before Upgrading:

After Upgrading:

Cause

Confluence Questions plugin modules will only be loaded if the plugin upgraded properly without errors. If anything blocked the upgrade (such as internal errors, data corruptions, or licensing problems) the plugin will not load all it's modules. This will cause the menu button to disappear.

Workaround

  1. Go to Manage Add ons.
  2. Uninstall the Confluence Questions Plugin.

    You will not lose any data from the plugin by uninstalling.

  3. Download the previous version of the plugin.
  4. Check if the button appears once again.

Once the Confluence Questions plugin is again working as expected, make sure to open a ticket at support.atlassian.com with a support zip so that we may investigate why the upgrade of the plugin failed.

 

Resolution

In some cases this behaviour can also happen if the add-on has problems retrieving it's license during the upgrade task. To address this error please do the following:

  1. Go to Confluence Admin > Manage Add-ons.
  2. Expand the Confluence Questions Plugin.
  3. Erase all the license information and click "Update".
  4. Then add you license and click "Update" one more time.
  5. Check if the modules appear as expected.

Last modified on Feb 26, 2016

Was this helpful?

Yes
No
Provide feedback about this article
Powered by Confluence and Scroll Viewport.