Documentation for Crowd 2.8. Documentation for earlier versions of Crowd is available too.

Skip to end of metadata
Go to start of metadata

The following instructions have been tested on Debian 6.0.1a. Other versions may require variations to this procedure.


  1. Open a terminal on the system, change to a suitable working directory, and enter the following command:

  2. Enter the root password when prompted.
  3. Enter the following commands:

  4. Enter the root password when prompted.
  5. Everything you need should now be installed and Apache should restart. If Apache fails to start, check the /var/log/apache2/error.log file.

Now that the software is installed, the next step is to configure Apache authentication.

  • No labels


  1. Anonymous

    If you have libapache2-mod-php5, it requires apache2-mpm-prefork and cannot work together with apache2-mpm-worker. So if you run above apt-get query it will remove php5 from your apache (tongue)

  2. Anonymous

    The 2.0.2 version shows an error during configure:

  3. Anonymous

    It seems that ./configure looks for the httpd binary and the /etc/apache2/httpd.conf configuration file. In Debian there are actually called apache2 and /etc/apache2/apache2.conf respectively.  When changing this in and running autoreconf --install, ./configure and make went fine.

  4. Anonymous

    The version 2.0.2 shows up [notice] mod_authnz_crowd 2.0.2 installed, during apache start, and it does not respect Apache logging level that is WARN.

  5. Version 2.2.2 on Debian 7 (wheezy) the result on "make install" is the following error message. There seem to be some incompatibility with libsvn?

    apache2: Syntax error on line 244 of /etc/apache2/apache2.conf: Syntax error on line 1 of /etc/apache2/mods-enabled/authz_svn_crowd.load: Cannot load /usr/lib/apache2/modules/ into server: /usr/lib/apache2/modules/ undefined symbol: svn_fspath__canonicalize
    Action 'configtest' failed.


    Unfortunately there's something wrong with either my account or JIRA so I'm not able to report a bug properly...

    1. Are you are using a version of SVN other than 1.6, by any chance? 1.6 is the only version of SVN that the Crowd Apache SVN Connector is compatible with.

  6. I get the error using subversion 1.6.17.

    I was looking through the code of the crowd connector and in the mod_authz_svn_crowd.c it says "This file is based on mod_authz_svn.c from Subversion 1.6.13" which confirms what you say. BUT, looking into the subversion 1.6.13 source code, there are no occurrance of "svn_fspath__canonicalize", in 1.7 there are.

    I would like to state that version 2.2.2 of the Crowd Connector for Apache requires Subversion 1.7. Looking at the Subversion source code, svn_fspath__canonicalize is new since 1.7...

    Edit: I haven't tested it yet using a configuration, but apache accepts the configuration and the mod.