Crowd is unable to find tables in the database

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Platform notice: Server and Data Center only. This article only applies to Atlassian products on the Server and Data Center platforms.

Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.

*Except Fisheye and Crucible

Problem

Crowd can't find database tables, even though the schema was created successfully:

ERROR [console.action.setup.Database] Database configuration failed. Schema creation complete, but database tables don't seem to exist.

Cause

There are three known causes:

1. The string "crowd.home" was used in the value of the crowd.home property in the <Crowd-Install>/crowd-webapp/WEB-INF/classes/crowd-init.properties file.

2. The database being used does not support the dialect set during the installation process.

3. The database user does not have the right permissions on the database to create, update or alter tables.

Resolution

1. Define a Crowd Home Directory Name without the crowd.home string (since this string is already used to name the home directory variable). This problem was reported as a bug and fixed for Crowd 2.0.2.

2. Change the database dialect to one that is supported by the current DB server. If you are not sure what dialect to use, then please contact Atlassian Support for further assistance.

3. Assign the right permissions to the database user that is used to connect to Crowd. See Connecting Crowd to a Database for instructions on configuring your database.

Last modified on Mar 30, 2016

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