Unable to connect Crowd to Azure AD due to multi-factor authentication
Platform Notice: Data Center Only - This article only applies to Atlassian products on the Data Center platform.
Note that this KB was created for the Data Center version of the product. Data Center KBs for non-Data-Center-specific features may also work for Server versions of the product, however they have not been tested. Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.
*Except Fisheye and Crucible
Summary
Crowd is unable to connect to Azure AD due to multi-factor authentication.
Environment
Crowd 3+
Azure AD
Diagnosis
To confirm, check if multi-factor authentication is enabled on your Azure AD instance: Configure Azure Multi-Factor Authentication settings.
Cause
Microsoft enabled multi-factor authentication in its Security defaults policy: Partner Security Requirements
Crowd does not currently support multi-factor authentication, as explained here: Configuring Azure Active Directory with Crowd.
It is also not possible to exclude the Crowd native app registration from Multi-Factor Authentication (MFA) in Azure AD: CWD-5310.
Solution
Multi-factor authentication must be disabled in Azure AD in order for Crowd to connect successfully: Configure Azure Multi-Factor Authentication settings.
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