Crucible reviews fail with no local entity with key error

Platform Notice: Data Center Only - This article only applies to Atlassian products on the Data Center platform.

Note that this KB was created for the Data Center version of the product. Data Center KBs for non-Data-Center-specific features may also work for Server versions of the product, however they have not been tested. Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.

*Except Fisheye and Crucible

Symptoms

Symptom #1: The following error is displayed on screen after navigating to Administration > Project Settings > Projects and selecting Application Links:

1 2 3 No entity exists with key ${helper.project.key} of type com.atlassian.applinks.api.application.fecru.FishEyeCrucibleProjectEntityType Status code: 400

Symptom #2: The following error is displayed on screen after clicking on "Reviews" or anything else having to do with Crucible:

1 2 3 4 5 6 7 8 9 10 Your request was unable to be processed javax.servlet.ServletException - javax.el.ELException: java.lang.IllegalArgumentException: No local entity with key 'grf2' and type 'class com.atlassian.applinks.application.fecru.FishEyeCrucibleProjectEntityTypeImpl' exists javax.el.ELException: java.lang.IllegalArgumentException: No local entity with key 'grf2' and type 'class com.atlassian.applinks.application.fecru.FishEyeCrucibleProjectEntityTypeImpl' exists java.lang.IllegalArgumentException: No local entity with key 'grf2' and type 'class com.atlassian.applinks.application.fecru.FishEyeCrucibleProjectEntityTypeImpl' exists No local entity with key 'grf2' and type 'class com.atlassian.applinks.application.fecru.FishEyeCrucibleProjectEntityTypeImpl' exists You are running release CR2.7.13 FE2.7.13 (20120517072828 2012-05-17), please report your release number when reporting bugs. Got a problem or a suggestion? Discuss it in the online forums or visit the support website for your support options.

Cause

This is a verified bug in the code. The following report has been created and voting is highly encouraged so please log in and vote!

Resolution

Go to Administration – note that you may need to click on Source first since the error screen doesn't allow anyone to log in. Next, Security Settings > Permission Schemes and "edit" every scheme under the "View" permission (you must "edit" here again) and check the box for "Allow All logged in users".

Updated on April 8, 2025

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