Hipchat Server is stuck on the configuration wizard
Platform notice: Server and Data Center only. This article only applies to Atlassian products on the Server and Data Center platforms.
Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.
*Except Fisheye and Crucible
This is for an outdated version of Hipchat Server
This article applies to a version of Hipchat Server which will be deprecated soon. After that period the version will no longer be supported.
You should upgrade to a more recent version of Hipchat Server as soon as you can to take advantage of new features, and security and bug fixes.
Symptoms
After installing Hipchat Server and browsing to the configuration wizard on the Web, clicking Getting Started or any other option just refreshes the page and the user is stuck on the configuration wizard.
Cause
Usually this occurs when somehow the setup wizard is started and isn't finished (i.e. reboot in the middle). This leaves the FQDN and possibly the Admin user email modified which makes the Setup Wizard no longer function.
Workaround
Use the Hipchat CLI to run: hipchat service --disable-setup-wizard to disable the setup wizard
Verify that the Administrator (first user/owner) email address has been set correctly with: hipchat service --reset-owner=EMAIL
In versions earlier than Hipchat Server v1.3 build 1.3.5, run: hipchat service --reset-login newemail@example.com
All further desired configuration (license, ssl, etc.) can occur normally via WebUI https://example.com/server_admin or the CLI.