Skip to end of metadata
Go to start of metadata

Below are the system requirements and installation instructions for the Atlassian Connector for Eclipse.

On this page:

System Requirements

The following platforms are supported for the Atlassian Connector for Eclipse. Please see Supported Platforms - Atlassian Connector for Eclipse for further details.

Atlassian Products

 

JIRA (1)

(tick) 5.0+

(tick) [3.13+, 5.0) (Connector 3.0.x)

FishEye (1)

(tick) 2.2.x, 2.1.x, 2.0.x

Bamboo (1)

(tick) 2.2.4+

Eclipse IDE

 

Eclipse IDE (2)

(tick) 4.4.x, 4.3.x, 4.2.x, 3.7.x

Mylyn

 

Mylyn

(tick) 3.8.4+

Operating Systems

 

Microsoft Windows (including 64-bit)

(tick) XP/2003/Vista/7/8

Linux (x86/GTK)

(tick) Ubuntu 10.04+
i.e. latest version

Apple Mac OS X

(tick) 10.5+

Notes

  • JIRA: Connector 3.0.8 and earlier, requires JIRA SOAP/RPC services running on the JIRA server (i.e. enable the RPC plugin).
  • Mylyn: If you do not already have Mylyn, it will be installed automatically when you install one of the Atlassian Connector's features. If you already have Mylyn installed, please check your version of Mylyn. If your version of Mylyn is earlier than 3.8.4, please upgrade to Mylyn 3.8.4 or newer.

Installation via the Eclipse Marketplace for Eclipse 3.7 (Indigo), 4.2 (Juno), 4.3 (Kepler), 4.4 (Luna)

You can install the Atlassian Connector for Eclipse via Eclipse Marketplace Client. Simply launch the Eclipse Marketplace Client ('Help' -> 'Eclipse Marketplace'), search for 'Atlassian' and follow the prompts to install.

Screenshot: Installing the Atlassian Connector for Eclipse via the Eclipse Marketplace Client

Installation via update site for Eclipse 3.7 (Indigo), 4.2 (Juno), 4.3 (Kepler), 4.4 (Luna)

You can also install the Connector via the Eclipse software updates manager, as described below.

To install the connector on a clean Eclipse IDE for Java Developers:

  1. Open the Eclipse software updates manager via 'Help', 'Install New Software'.
  2. Click 'Add'. The 'Add Site' window will display.
  3. Enter the details of the update site (see Eclipse Update Sites section above) and click 'OK'.
  4. The 'Available Software' screen will appear again. Select 'All Available Sites' in the 'Work with' dropdown list.
  5. Select both 'Atlassian Connector' categories:

  6. Click 'Next' and follow the installation prompts.
  7. Restart Eclipse when prompted.

 

Eclipse Update Sites

Add the following URL to your Eclipse update sites:

There is also nightly update site available, for those who are keen to get the latest version of the connector. Builds are executed every night:

JIRA Compatibility note

Icon

Atlassian Connector 3.2.x is compatible with JIRA 5.0 and newer.

Atlassian Connector 3.2.x  consumes JIRA REST API instead of the old SOAP, RSS, WEB API used in version 3.0.8 and earlier.
JIRA REST API allows to retrieve more information from JIRA and gives more flexibility when comes to issue update. It allowed to significantly improve custom fields support. Issue editor is now able to display most of the custom field types and allows to edit them.

JIRA authentication note

Icon

Atlassian Connector 3.2.x uses HTTP Authentication to connect to JIRA instead of form authentication used in version 3.0.8 and earlier.

If your JIRA server is running behind a reverse proxy, and the reverse proxy requires separate HTTP authentication, the credentials for the reverse proxy must match the credentials for JIRA. Please also make sure that reverse proxy does not remove Authorization: header from the HTTP request.

For more information see release notes.

 

Offline Installation

If you cannot use our update site (e.g. due to firewall issues) or just prefer local installation, we offer a zipped version of the entire update site (you still may need to install Mylyn first as it is required by Atlassian Connector and not bundled in the zip).

  1. Download the Atlassian connector's from
    1. zipped update site (version 3.2.x)  - the same file for Eclipse 3.7, 4.2, 4.3, 4.4 or
    2. zipped update site (version 3.0.x) and JIRA below 5.0 or
    3. old zipped update site for Eclipse 3.6 and 3.5 or
    4. nightly zipped update site (latest version 3.2.x) - the same file for Eclipse 3.7, 4.2, 4.3, 4.4
  2. In Eclipse, open 'Help, 'Install New Software', 'Add', click the 'Archive' button and select the downloaded zip file.
  3. Continue with the installation steps as described for the regular update site — see instructions below.

Installing a Previous Version

Icon

Atlassian does not support older releases of the plugin.

Add the following URL to your Eclipse update sites:

The last version of the connector containing Crucible support is 2.3.0:

Troubleshooting the Installation

Please refer to the list of installation FAQ:

Related topics

 

 

170 Comments

    1. Thank you. Updated.

      Kind Regards,
      Andrew

  1. Anonymous

    Could you also provide zipped update site for Helios (3.6)?

    1. Hi,
      The same zipped update site works with Eclipse 3.5 and Eclipse 3.6. Just use http://update.atlassian.com/atlassian-eclipse-plugin/e3.5-site-all.zip

      Cheers,
      Wojtek

  2. Anonymous

    I'm constrained to using ganymede (Eclipse 3.4). From what your notes indicate above I should stcik to v2.1.0 of the connector, however, doing an update in eclipse wants to bring in v2.2.0. Should I go ahead and do it?

    1. Connector 2.2 will not work with Eclipse 3.4 (at least in some places - like JIRA select project wizard page). It may work in other places (like Bamboo, FishEye or Crucible) but try it out at your own risk.

      Older releases are available at update sites with the following URL pattern: http://update.atlassian.com/atlassian-eclipse-plugin/<x.y.z>/e3.4/ (e.g. http://update.atlassian.com/atlassian-eclipse-plugin/2.1.0/e3.4/ for Connector v2.1.0).

      Cheers,
      Wojtek

      Updated: actually I checked that we now sometimes depend on Eclipse 3.5+ API.

  3. How do I get the complete source for the Connector 2.2 and all dependent jars (eclipse 3.5)?

    I have svn setup with https://studio.atlassian.com/svn/PLE/trunk but I'm not sure which revision to synch to and if it will get me all dependencies.

    Ivan

    1. Hi Ivan,

      Please take a look at https://studio.atlassian.com/wiki/display/PLE/Setting+up+development+environment+for+Atlassian+Connector+for+Eclipse.

      You can find there instruction how to build development environment for Atlassian Connector for Eclipse.

      If you have a question please post a comment there.

      Best,

      Jacek

  4. Anonymous

    Hello, I have a problem with installation for Eclipse 3.6.

    On "Review Licenses" screen button Next is disabled.

    I had reviewed all licenses texts and check on "I accept the terms...." button. But it still disabled. Could you help please.

    1. Anonymous

      Please ignore this messge

      1. Anonymous

        I have the same problem, Next is disabled. What is the solution?

        1. Have you checked 'accept license' radio button? Is 'Finish' enabled? If yes then just press it and it will start the installation.

  5. Tyring to install atlassian connector from the market place for helios and stuck at 27% for 2hrs. The progress indicator says it is installing software: Fetching org.eclipse.mylyn.commons.soap_3.4.0.v20100608-01...xml/plugins/org.eclipse.mylyn.commons.soap_3.4.0.v20100608-0100-e3x.jar.pack.gz

    Just wondering if the install really takes a long time or something with the install is messed up.

    Cheers,
    Harold

    1. Solution was to install the Mylyn Commons first then it all worked.

      1. Anonymous

        i am having the same problem when trying to install mylyn connector from the market place  (it is taking a long time). How did you install mylyn commons?

        1. Just browse http://download.eclipse.org/mylyn/releases/latest update site in your Eclipse and look for Mylyn commons or whatever you need.

  6. Anonymous

    I install the Connector3.0 successful, but on the "Add task repository" can't see the "'Crucible'" item, only "JIRA" and "'Bamboo'", who can help me on it?

    1. Hi,

      Connector 3.0 does not support Crucible anymore. The last version with Crucible support is 2.3.

      Cheers,
      Jacek

      1. Anonymous

        I was expecting to see Crucible/FishEye too, since it's in a screenshot in this page and in plugin documentation in several other places.

        1. You are right. We will change the screenshot.
          We will also review documentation once again.

          Thanks,
          Jacek

        2. I have fixed plugin documentation in several places.

      2. Anonymous

        Is Crucible support planned for future releases?

        1. At this time we do not plan to restore Crucible integration.

          1. Can you explain why Crucible integration was removed and there are no plans to restore it? Thanks.

          2. Anonymous

            I'd also like to know why crucible support was discontinued.

  7. Anonymous

    What version(s) of Crucible are supported by Connector 2.3.0 ?

    1. According to the list at the top of the page it works fine till 2.2.x (2.2.3 is the latest). Nevertheless it may work OK with some newer versions up to 2.3.6 but of course there is no guarantee.

  8. Anonymous

    Eclipse does not easily give you the version number.  When starting it displays the name such as 'Ganymede'.  If you choose Help/About it also doesn't tell you the version number.  Please add to the install guide how to get the version number, or use the same names that Eclipse uses for the version.

    1. Hi,

      Most of Eclipse distros in fact hide the version number. If you cannot see the version string in Help | About (e.g. SDK distros show there the version), click Installation Details and look for the version of "Eclipse Platform" or "org.eclipse.platform" in the text box with all listed plugins.
      Alternatively follow http://stackoverflow.com/questions/2313660/eclipse-version.

      I'll adjust the documentation here to include the names of Eclipse releases in our update site list.

  9. Anonymous

    I don't see any mention of JIRA 4.2.x being supported by this connector -- is it supported?

    1. Yes. JIRA 4.2.x is supported as well as 4.3.x.

      1. I'm having trouble installing the off-line archive with Eclipse 4.2.

        It cannot find the org.apache.jasper dependency.

        According to the M4 release notes, the org.apache.jasper package has been replaced.

         

        FWIW if I install interactively in the running Eclipse, it finds the dependency somewhere. But I need offline installation in an enterprise setting.

        Created as an issue.

  10. Anonymous

    http://blogs.atlassian.com/devtools/2011/02/atlassian-ide-connector-30.html

    Atlassian IDE Connector has zero value without crucible support for me. Absolutely useless. The only feature I used was creating crucible review from eclipse IDE.

    1. Anonymous

      Me too.

      Our department just bought 50 licences. Just to find out it doesn't work with newer eclipse versions anymore because these guys dropped the support for it.

      WTF ?!!

      Can anyone suggest an alternative to crucible ? No eclipse integration means we have to switch to another product.

  11. Anonymous

    I don't see any mention of Mylyn 3.6 and Eclipse 3.7 ? Will they be soon supported ?

    1. They are supported.

      We are switching our continuous integration infrastructure to make it compatible with newest Eclipse and Mylyn. When it is done and all tests pass we will update compatibility information on the page.

      Cheers,
      Jacek

      1. Anonymous

        How are you doing on supporting Eclipse 3.8/4.2?

        1. We will work on that soon. Please watch the page to get notification once it is done.

  12. Anonymous

    I just installed Indigo and added the weekly update site.  I get this error when I try to install the Atlassian connector:  What am I missing?

    Cannot complete the install because one or more required items could not be found.
      Software being installed: Atlassian Connector for Eclipse (Required) 3.0.1.I20110729-0900 (com.atlassian.connector.eclipse.feature.group 3.0.1.I20110729-0900)
      Missing requirement: Mylyn Connector: JIRA (Compatibility) 3.4.0 (org.eclipse.mylyn.jira_feature.feature.group 3.4.0) requires 'com.atlassian.connector.eclipse.jira.feature.group 3.0.1.qualifier' but it could not be found
      Cannot satisfy dependency:
        From: Atlassian Connector for Eclipse (Required) 3.0.1.I20110729-0900 (com.atlassian.connector.eclipse.feature.group 3.0.1.I20110729-0900)
        To: com.atlassian.connector.eclipse.jira.feature.group [3.0.1.I20110729-0900]
      Cannot satisfy dependency:
        From: Atlassian JIRA Connector (Recommended) 3.0.1.I20110729-0900 (com.atlassian.connector.eclipse.jira.feature.group 3.0.1.I20110729-0900)
        To: org.eclipse.mylyn.jira_feature.feature.group 3.4.0

      1. Resolved

        Try this:

        1. Install Mylyn in a normal way
        2. Restart Eclipse Indigo
        3. Open Planning Perspective
        4. Open Task Repositories View
        5. Right click, and select Add Task Repository
        6. In the opened dialog, click Install More Connectors...
        7. Select Atlassian JIRA
        8. Click Finish and after installation complete, restart Eclipse again.
        9. Use the Atlassian Connector
        10. Pay a beer (wink)

    1. The simpler solution which also costs no beer is to explicitly mark JIRA Connector on the 'items to install' list. If you can't find it then uncheck 'group by category' checkbox.

  13. Anonymous

    I would like to install the eclipse plug-in on a standalone system (not connected to the network).  Is there a zip file I could download and copy to a thumb drive

    1. See "Offline Installation" section on this very page above.

  14. FYI: I can install the Eclipse Connector, but when I go to do so, Eclipse complains "Warning: You are installing software that contains unsigned content. The authenticity or validity of this software cannot be established. Do you still want to continue with the installation?"

    Could you please sign your jar files?

  15. Anonymous

    Any release date (or snapshot) for 3.0.3 support for JIRA5.

  16. Hi,

    The snapshot of 3.0.3 with JIRA 5 compatibility is already available. Take it from our weekly update site.

    Cheers,

    Jacek

  17. Anonymous

    It would be nice if screenshot that indicates crucible integration is available would be removed... it really really confuses.

    1. Hi,

      Which screenshot do you mean? Is there any?

      We could probably remove Crucible from Requirements/Compatibility table.

      Cheers,

      Jacek

       

  18. Anonymous

    why is crucible removed?

     

  19. Anonymous

    time to update for Eclipse 4.2, please

     

  20. Alassian Connector for Eclipse 3.0.6 is compatible with Eclipse 4.2 and Mylyn 3.8.

     

    1. Update doesn't work. It says:

      No repository found containing: osgi.bundle,javax.ejb,3.1.1.v201204261316
      1. What version/distribution of the Eclipse do you use?

        1. Eclipse Juno 4.2, buildId: 20120614-1722

        2. Eclipse JEE Juno, buildId: 20120614-1722.

      2. I tried with Java and Classic and it worked fine. Can you try to proceed with install instead of upgrade? If it does not work then I will look into that closer.

        Thanks,

        Jacek

        1. Ok, I did the following:

          1. Launched Eclipse for JEE developers 4.2 on Mac OX 64.
          2. Added the following udpate site: http://update.atlassian.com/atlassian-eclipse-plugin/e3.8/
          3. Selected Atlassian Connector for Eclispe 3.0.6
          4. Checked to search for dependencies as well
          5. Accepted agreement
          6. Exception was raised:
          An error occurred while collecting items to be installed
          session context was:(profile=epp.package.jee, phase=org.eclipse.equinox.internal.p2.engine.phases.Collect, operand=, action=).
          No repository found containing: osgi.bundle,javax.ejb,3.1.1.v201204261316
          1. Works fine on my side with Eclipse Juno JEE on Windows. It might be something related to the Eclipse version for Mac or your Eclipse installation is broken.

            Could you try to:

            • Repeat the installation on the fresh Eclipse instance? I would like to confirm that it is not a clash with other plugin or result of some manual changes.
            • Try to install other plugin? I wonder if it fails. We do not use ejb directly so it does not look like Atlassian Connector fault at first sight.

            Thanks,

            Jacek

             

              • On fresh install everything went without problems. But I still can't install on my current install with some other plugins installed already.
              • I can install other plugins however, like GWT, Vrapper, etc.

              It's probably Eclipse bug.

              1. It might be. It also might be that one of your plugins breaks/blocks something.

                If you don't have many plugins installed you can try to adjust fresh Eclipse copy and install plugins one by one.

                I hope you will manage to get it working.

                Cheers,

                Jacek

            1. Solved by removing all update sites.

              1. Ahhh, great! Congratulations!

                 

  21. Anonymous

    Hi,

    FYI it did not work for us as well (eclipse jee 4.2)

    From the market place or from the 3.8 update site, it was not possible to install the JIRA connector for Mylyn

    1. I would need to know more details in order to help you. Please raise an issue at support.atlassian.com and we will try to figure out what's wrong.

       

  22. Anonymous

    Trying to install connector in Eclipse Juno JEE. Have also tried the non-weekly update site as well as through the marketplace, both of which have the same error. It appears that Eclipse adds 'content.xml' to the URL which results in a 404 when accessed through a web browser.

    Error
    Tue Aug 14 14:51:05 CAT 2012
    Unable to connect to repository http://update.atlassian.com/atlassian-eclipse-plugin/weekly/e3.8/content.xml

    java.net.ConnectException: Connection refused: connect
    at java.net.PlainSocketImpl.socketConnect(Native Method)
    at java.net.PlainSocketImpl.doConnect(PlainSocketImpl.java:351)
    at java.net.PlainSocketImpl.connectToAddress(PlainSocketImpl.java:213)
    at java.net.PlainSocketImpl.connect(PlainSocketImpl.java:200)
    at java.net.SocksSocketImpl.connect(SocksSocketImpl.java:366)
    at java.net.Socket.connect(Socket.java:529)
    at org.eclipse.ecf.provider.filetransfer.events.socket.SocketEventCreateUtil.createSocket(SocketEventCreateUtil.java:43)
    at org.eclipse.ecf.internal.provider.filetransfer.httpclient.ECFHttpClientProtocolSocketFactory.createSocket(ECFHttpClientProtocolSocketFactory.java:81)
    at org.eclipse.ecf.internal.provider.filetransfer.httpclient.ECFHttpClientProtocolSocketFactory.createSocket(ECFHttpClientProtocolSocketFactory.java:73)
    at org.eclipse.ecf.internal.provider.filetransfer.httpclient.ECFHttpClientProtocolSocketFactory.createSocket(ECFHttpClientProtocolSocketFactory.java:65)
    at org.apache.commons.httpclient.HttpConnection.open(HttpConnection.java:707)
    at org.apache.commons.httpclient.MultiThreadedHttpConnectionManager$HttpConnectionAdapter.open(MultiThreadedHttpConnectionManager.java:1361)
    at org.apache.commons.httpclient.HttpMethodDirector.executeWithRetry(HttpMethodDirector.java:387)
    at org.apache.commons.httpclient.HttpMethodDirector.executeMethod(HttpMethodDirector.java:171)
    at org.apache.commons.httpclient.HttpClient.executeMethod(HttpClient.java:397)
    at org.apache.commons.httpclient.HttpClient.executeMethod(HttpClient.java:346)
    at org.eclipse.ecf.provider.filetransfer.httpclient.HttpClientFileSystemBrowser.runRequest(HttpClientFileSystemBrowser.java:232)
    at org.eclipse.ecf.provider.filetransfer.browse.AbstractFileSystemBrowser$DirectoryJob.run(AbstractFileSystemBrowser.java:69)
    at org.eclipse.core.internal.jobs.Worker.run(Worker.java:54)

     

    1. Indeed there is no content.xml file. It is located inside content.jar. The following link works fine: http://update.atlassian.com/atlassian-eclipse-plugin/e3.8

      Please try once again and let us know if you still cannot install the plugin.

      Cheers,
      Jacek

      1. Anonymous

        Hi, 

        I still get an error using this update site but I think it may be network related: I get errors with other update site as well. I have since worked around this by downloading the archived site and installing manually.

        Thanks

  23. Adding the above update site (http://update.atlassian.com/atlassian-eclipse-plugin/e3.8) to a new Eclipse 3.8 installation results in this error:

    I guess the last double slash in the content.xml link is incorrect.

    Thanks, Jörg

    1. It works fine on my side. Can you let me know your Eclipse version, distribution (java, java ee, etc.), architecture (32 or 64bit) and OS?

      Thanks,
      Jacek

      1. Sure, Jacek:

        Eclipse 3.8 based on the classic bundle from the Eclipse project site (http://download.eclipse.org/eclipse/downloads/eclipse3x.html).

        Here are the extra plugins installed (in this order) – just in case you need that information:

        PluginEclipse Feature
        Names / Group 
        DescriptionVersionMinimalDefaultJEE
        Base Installation...installation package downloaded from Eclipse siteeclipse-SDK-3.8-linux-gtk.tar.gzSDKSDKSDK

        Subversive – SVN Team Provider

         Provides Subversion integration1.0.0.I20120803-1700xxx
        SVN Kit Connector (Polarion) Subversion 1.6 library (pure java)

        3.0.0.I20120818-1700

        xxx
        Groovy Eclipse Support the Groovy language2.7.0.xx-20120703-1400-e42-RELEASExxx
        DTP SQL Editor Syntax highlighting for SQL files1.10.0.v201201161512xxx
        Apache Ivy IDE Ivy dependency management for ant2.2.0.beta1-201203282058-RELEASExxx

        m2eclipse including

        • wtp 
        • Groovy
        • builder-helper-maven-plugin
         Maven integration

        1.1.0.20120530-0009

        xxx
        ShellEd Shell script editor with syntax highlighting2.0.2xxx
        Mylyn Task Context and Repository access3.8.1
        xx
        Atlassian Connector for Eclipse Access to JIRA repositories3.0.6
        xx

        My OS is Linux Ubuntu 11.04 (natty) 32bit.

        My workaround was to use the Eclipse Market Place to install the connector. At least that worked for me (smile)

        Thanks and regards, Jörg

        P.S. Please remember to delete my comments if the issue has been resolved – should have filed an issue instead...

        1. I tried this version on Windows and again works fine. I will try it on Ubuntu later on.

          The Marketplace points to the same update site so there should be no difference. There must be something specific with your environment. Hopefully you managed to make it work.

          1. Yes, as mentioned above I got it working with the Eclipse Market Place (which is simpler anyway). Just wanted to report the issue I found.

            Cheers, Jörg

        2. Tested Eclipse 3.8 Classic on Ubuntu 11.04 32bit and http://update.atlassian.com/atlassian-eclipse-plugin/e3.8 update site works well. That must have been some temporary issue or something specific to your local env. 

          Installation from Marketplace worked fine so I'm not going to investigate it more.

          Cheers,
          Jacek 

  24. I'm having issues with installing this old version (my client uses JIRA Enterprise Edition, Version: 3.7.3-#187):http://update.atlassian.com/atlassian-eclipse-plugin/2.1.0/e3.4

    Any idea what can I do or can I install another version of the connector that's compatible with this JIRA version? This problem should not be related to my eclipse version (indigo) right?

     

    An error occurred while collecting items to be installed
    session context was:(profile=epp.package.jee, phase=org.eclipse.equinox.internal.p2.engine.phases.Collect, operand=, action=).
    No repository found containing: osgi.bundle,com.atlassian.connector.commons,4.0.0.v20110210
    No repository found containing: osgi.bundle,com.atlassian.connector.eclipse.commons.core,3.0.0.v20110210
    No repository found containing: osgi.bundle,com.atlassian.connector.eclipse.core,3.0.0.v20110210
    No repository found containing: osgi.bundle,com.atlassian.connector.eclipse.monitor.core,3.0.0.v20110210
    No repository found containing: osgi.bundle,com.thoughtworks.xstream,1.3.0.v20100826-1640

     

    Thank you,

    Corneliu

  25. Hi,

    Unfortunately none of the Eclipse Connector versions work with JIRA 3.7.3. More, version 2.1.0 will most likely fail on Indigo.

    Cheers,
    Jacek 

    1. Ok, thank you for clarifying this for me.

       

      All the best,

      Corneliu

  26. Anonymous

    Any idea what the "Obsolete {CVS, Perforce, Subclipse, Subvserive} Atlassian components are?

    1. Hi,

      Before they became obsolete, they were used for Crucible integration which allowed to create reviews for sources versioned under few most popular VCS providers.

      Cheers,
      Jacek

  27. Hello Jacek,

    I wonder what the weekly / nightly update sites contain. Do you have any ticket or check-in references?

    The version on the weekly update site is currently named 3.7.0 but the JIRA milestone does not contain any closed tickets.

    Would be great if you could update this page in order to shed some light on this (smile)

    Thanks, Jörg

  28. Hello Jacek,

    the release notes for 3.1 are still restricted (I cannot read them), but I assume you remember to remove restrictions as soon as they are complete.

    Cheers, Jörg

    1. Sure. I have just published them.

  29. Hello Jacek,

    now as you have released the wonderful new 3.1 and 3.2 version of the connector, there are some sites which still have JIRA 4.0, most notably http://java.net/jira/secure/Dashboard.jspa.

    Since I cannot influence whether and when they will upgrade – ist there any way to run both connectors in parallel?

    Thanks, Jörg

    1. Hi Jörg,

      Version 3.0.7 is still available and functional but it is not possible to run both of them (3.2 and 3.0.7) within the same Eclipse instance.

      Cheers,
      Jacek

  30. Anonymous

    Hi Jacek,

    I am using eclipse 3.5.  I see in the prerequisites for configuring atlassian connector that we need Mylyn 3.8. But while I installed the connector it installed Mylyn 3.4. Do I have to upgrade my mylyn or version 3.4 is good enough for eclipse 3.5? Please clarify

    1. What version of Atlassian Connector have you installed? The newest version will not work with Mylyn 3.4 correctly and you may expect issues in few places.

      Why not to upgrade your Eclipse and Mylyn?

      Cheers,
      Jacek

  31. Anonymous

    Hi Jacek,

    I have installed Atlassian connector version 3.0. I used the eclipse3.5 update site url that is given in under the topic Installing a Previous Version. This installed mylyn 3.4 in my system, this is why I inquired whether up-gradation to 3.8 is required?

    Thanks,

    Priya

    1. Hi Priya,

      You don't need to upgrade Mylyn.
      Actually you even can't upgrade Mylyn to 3.8 because it does not work with Eclipse 3.5.

      Cheers,
      Jacek

  32. Anonymous

    Are you planning to add support for Stash to the eclipse connector? Or are there third party plugins available?

    1. What kind of support/integration would you like to have?

      I'm not aware of any existing plugin but we did some research and one of the possible integrations could be to list Stash pull requests in Eclipse.

      Cheers,
      Jacek

  33. Anonymous

    Hi Jacek,

    I would most definitely be interested in:

    • submitting new pull requests 
    • listing the open, merged and declined pull requests 
    • quickly jumping to Stash in the browser to comment on code reviews and so on ( and vice versa from browser to the IDE?)
    • overview of recent activity
    • integrated search - though the search feature seems rather limited in Stash compared to Fisheye.

    To give you some background, the projects we work on generally involve many repositories, changes often need be made to several repositories at the same time. This made is 'easier' for us to move from a mix of clearcase and SVN to git. We use repo to manage this workflow. We are currently using Fisheye and reviewboard, but are currently evaluating both Stash and gerrit. 

    We will probably extend repo to at least submit pull requests for multiple repositories via command line. However, it would be nicer to be able to do this directly from Eclipse, particularly if you're able to submit pull requests for multiple repositories at the same time (provided the src and dest branch names are same across the repositories which is always the case for us). 

    Activity overview at the Project level would also be a fantastic feature, something I am surprised Stash doesn't already have?

    cheers,

    Bryan 

    1. I have created a ticket for Stash integration. Let's continue discussion there: https://ecosystem.atlassian.net/browse/PLE-1500.

      Cheers,
      Jacek

  34. Anonymous

    It seems that the nightly update site

    did not work today. Is this expected?

     

  35. It seems that the nightly update site

    did not work today. Is this expected?

  36. Anonymous

    Does the JIRA connector work with Eclipse 4.3 (Kepler)?
    I am able to create a Task Repository - also getting a validation successfull message on my credentials - but if i try to create a query i am not able to update from repository. In 4.2 everything works fine, I can synchronize with repo and work on items, but with 4.3 it does not work anymore.

    JIRA 5.1
    Eclipse 4.3 (Kepler) 

    1. Hi,

      It should work fine. I assume you mean 'Update from Repository' button for the predefined filters list. Am I right?

      Can you raise an issue at https://ecosystem.atlassian.net/browse/PLE and give us more details? What happens if you press the button? Do you get any error message? Is there anything in the Eclipse log?

      Thanks,
      Jacek

  37. Anonymous

  38. Anonymous

    Update site is not working for Kepler Eclipse 4.3

    It returns an HTTP 301 code which can not be handeld by eclipse. Looks like eclipse is appending an content.xml to the url which will result in an 301 code (also within the browser)

     

    1. I cannot reproduce the problem. Which update site link does not work for you? Have you tried to update or install the plugin? At what step it fails?

      One thing which changed is that our update site now redirects to https. Nevertheless the http url works fine on my side and Eclipse correctly installs the plugin.

      Please let me know the details and I will fix the issue.

      Thanks,
      Jacek

  39. Anonymous

    Take the link from Marketplace, use the link above.

    The problem is if you just use the link as it is it works:

    http://update.atlassian.com/atlassian-eclipse-plugin/rest/e3.6

    but eclipse seems to an context.xml

    http://update.atlassian.com/atlassian-eclipse-plugin/rest/e3.6/context.xml

    Thats the detail from the exception within eclipse (content.xml was automatically added.):

    HTTP Server Unknown HTTP Response Code (301):http://update.atlassian.com/atlassian-eclipse-plugin/rest/e3.6/content.xml
    HTTP Server Unknown HTTP Response Code (301):http://update.atlassian.com/atlassian-eclipse-plugin/rest/e3.6/content.xml
    General connection error with response code=301

    Using the IE I get the same 301 code while using Google Chrome it gets forwarded to an https url which results into an 404

    1. I'm still not able to reproduce the issue. I tried to install Connector from both Marketplace and manually pasting the links to Install New Software dialog and everything works fine.

      Can you explain step by step what are you trying to do with this link? What do you click and where do you paste the link to get this error in the Eclipse?

      Thanks,
      Jacek

  40. Anonymous

    Click flow:

    Open Eclipse
    Menu->Eclipse Marketplace
    Search: Atlassian - All Markets - All Categories
    Click on GO

    Atlassian Connector for Eclipse is shown
    Click on install

    Check all entries and click Confirm

    And the error pops up:
    HTTP Server Unknown HTTP Response Code (301):http://update.atlassian.com/atlassian-eclipse-plugin/e3.8/content.xml
    General connection error with response code=301

    1. Thank you for step by step instructions. Still no luck unfortunately. I cannot reproduce the issue, even though I tried various networks to make sure company network setup is not an issue.

      What is your exact Eclipse distribution? Classic, JavaEE, other? Do you have a proxy?

      Thanks,
      Jacek

  41. Anonymous

    Its the Classic distribution.

    Eclipse Standard/SDK

    Version: Kepler Release
    Build id: 20130614-0229

    and yes I have to use our company proxy. Maybee the error is related to that one but I'm facing no such issues with other plugins and update sides. (Just building up a fresh eclipse installation)

    1. Eclipse scans for different files in the update site. There is no content.xml (but content.jar) and it may be that something in your proxy does not work well in that case (it gets 301 first and then 404).

      Can you try to install Connector from the following update site (https instead of http): https://update.atlassian.com/atlassian-eclipse-plugin/e3.8

      Thanks,
      Jacek

  42. Anonymous

    Already tried before and thats the output:

    Unable to read repository at https://update.atlassian.com/atlassian-eclipse-plugin/e3.8/content.xml.
    Unable to read repository at https://update.atlassian.com/atlassian-eclipse-plugin/e3.8/content.xml.
    java.util.NoSuchElementException

     

    1. Similar problems:

      Do you use Oracle Java? Could you ask your IT guys for assistance with the possible proxy issue?

      What is your operating system?

      Thanks,
      Jacek

  43. Anonymous

    Hi thanks the for links. I already found the second one and tried the vmargs without seeing any effects.

    Setting the proxys within eclipse seems not to work at all. Within Eclipse 4.2 I could enter proxy settings on my own and it worked. On eclipse 4.3 it creates errors and says in the log that a proxy port should be set which isn't.

    I'm using the regular Java JDK 1.6.41 64bit not the jrocket one.

     

    In the meantime I installed the offline version which is working for me. Btw. there is no version for JIRA 3.13.2 and Eclipse 4.3? We only have a newer JIRA as a test instance. The production one is still 3.13.2. The process to upgrade will take some time.

    1. Connector 3.0.8 works fine with Eclipse 4.3 but it is compatible with JIRA 3.13.5+ as far as I remember.

      WRT installation error I will ask our IT if the http->https redirection is necessary.

      Cheers,
      Jacek

  44. I was able to successfully install Connector on Eclipse 4.3 through the proxy.

    Our IT folks claim that http->https redirection is not new and was there for a long time. If "HTTP Server Unknown HTTP Response Code (301)" was the only one then we could try to disable redirection but you get another error for https: "Unable to read repository at".

    Would it be possible to talk to your IT guys and investigate the traffic performed through the proxy? It would be great to understand why the communication fails.

    Thanks,
    Jacek

  45. We're in the process of evaluating FE/CR.

    After spending days indexing, it was time to install the plugins for Eclipse.

    All screenshot pointed to a version supporting Crucible, but Eclipse Marketplace said otherwise.

    Until I found this blog.

     

    I am very displeased by this.

    We've been looking to replace Opengrok / Review Board for this product. For Review Board, we had to develop our own Eclipse plug-in since it was open source.

    But we Crucible at 4000$ a year, we are expecting to have everything ready and functioning out of the box.

     

    Now, not only will we pay to have Atlassian REMOVE key feature, we will either have to create our own plug-in or lose time toggling between the IDE and the browser.

     

    This was a bad idea.  Pulling content from a free product is understandable. But for enterprise that are paying many grands in support each year, seeing feature being REMOVED is unacceptable.

     

    In the end, our Dev team will take the decision and determine if Fisheye / Crucible is worth 8000$ annually. But the more I'm setting the product, the more I fear FECRU won't make the cut.

  46. Anonymous

    I just resolved the same (301) issue for myself.  Using MyEclipse IDE, and have had this problem with other update sites.  I switched the URI https, and maybe more importantly, removed the "Name" (now empty string) from the update site.  So I'm left only with the "Location".  I was able to reload the site successfully.

  47. Anonymous

    A question regarding the update sites switched from http to https, is that permanent? Meaning do you consider providing an update site via http in the future or is it going to be https now?

    1. Do you face any issues with https?

      1. Anonymous

        No, I'm asking only because I will need to update a bunch of files if the change turns out to be pemanent.

        1. What files will you need to update? Do you have some custom setup/installation procedure?

          I would like to understand if switch to https is painful in any way.

          Thanks,
          Jacek

          1. Anonymous

            Those are config files for a framework helping to discover existing Eclipse connectors.

            With all due respect, could you please answer my initial question? Or does mean you guys consider to switch back to http in case there are clients having issues with https?

            1. does mean you guys consider to switch back to http in case there are clients having issues with https?

              This is exactly what I wanted to say. From your answer I understand that you guys have a custom setup so I don't consider that as an issue.

              We want to release new Connector version (3.2.2) in 2-3 weeks and need to decide before that date. Let's wait for more feedback.

              Thanks,
              Jacek

  48. Anonymous

    It looks like the update site for Kepler ist ./e3.8, not ./e3.7. The documented update site does not work for me.

    BTW: Searching for JIRA should find the Atlassian Connector. It does not. Who searches for "Atlassian" in the first place?

    1. Hi,

      All update sites documented here are up and running. They are not Eclipse version dependent.

      Can you let me know what error message do you get and what update site do you use?

      Regarding the search, do you mean Eclipse Marketplace search? I get Connector on the 3rd or 4th position when searching for JIRA. I think that is good enough - we don't control how the Eclipse Marketplace search algorithm works.

      Thanks,
      Jacek

  49. Anonymous

    Cannot access http://update.atlassian.com/atlassian-eclipse-plugin/e3.8/content.xml via Internet Browser. Can access http://update.atlassian.com/atlassian-eclipse-plugin/e3.8/. Cannot access with Eclipse either.

    @Atlassian: There is something wrong with your update site setup.

    1. Cannot access http://update.atlassian.com/atlassian-eclipse-plugin/e3.8/content.xml

      Why do you want to access this link via browser? It is not listed anywhere in our documentation.

      http://update.atlassian.com/atlassian-eclipse-plugin/e3.8/

      It works fine on my side. What kind of error do you get? Can you try https://update.atlassian.com/atlassian-eclipse-plugin/e3.8/ (https instead of http)?

      I think there may be something wrong with your network (proxy?) setup which does not handle redirects well. Few customers reported that issue already. I think we should try to switch off redirection to https on our side.

      Thanks,
      Jacek

       

       

  50. Anonymous

    Unable to read repository at https://update.atlassian.com/atlassian-eclipse-plugin/e3.8/content.xml. Unable to read repository at https://update.atlassian.com/atlassian-eclipse-plugin/e3.8/content.xml. java.lang.ClassNotFoundException: com.ibm.websphere.ssl.protocol.SSLSocketFactory

    Eclipse Juno, note that all others sites works fine (market & updates sites) ...

     

  51. Anonymous

    Hey, I've got the connector installed, but I'm not able to set up the repository. We use Atlassian OnDemand and I log in using Google when accessing JIRA via web browser. What credentials/setup should I use to access it in Eclipse? Those for the Google account don't work. Cheers!

    1. Anonymous

      FWIW, it's JIRA 6.1 and the connector has been installed from http://update.atlassian.com/atlassian-eclipse-plugin/rest/e3.7

    2. Please try one of the following to set up your JIRA (not Google) password. The new password should work fine with Connector:

      • When you are logged into JIRA through the browser, please try to change your password or
      • Try can't access account link on the login page or
      • Ask your JIRA admin to set your password (you will be able to change it later).

      Cheers,
      Jacek

  52. Anonymous

    Version 3.6 now has an undocumented dependency on org.apache.commons.codec and won't install in neither Eclipse Keppler or Juno.

     

     

    1. The latest version of the Connector is 3.2.2. What do you mean by 3.6?

  53. Anonymous

  54. Hi - Does e3.4-site-all.zip exist? I would like to attempt an offline installation in Ganymede (the online installation does not work for me). Thank you. Sylvain

     

    1. I can see that version 3.4 was linked to 3.5 so you can try the following link: http://update.atlassian.com/atlassian-eclipse-plugin/e3.5-site-all.zip

      This is the oldest package we have.

      Cheers,
      Jacek

  55. I installed the Atlassian connector in my eclipse (Juno) from the site http://update.atlassian.com/atlassian-eclipse-plugin/rest/e3.7

    My JIRA url is https://jirarad.uk.fil.com/.  I am trying to add this JIRA url in the repository setting along with my userid and password. After adding these information i tried to validate the settings and i got the following error com.sun.jersey.api.client.ClientHandlerException: java.net.SocketException: java.lang.ClassNotFoundException: Cannot find the specified class com.ibm.websphere.ssl.protocol.SSLSocketFactory

     

    How can i fix this problem? Any help appreciated.

    1. Hi,

      Can you let us know what is your exact distribution? Is it a Classic, Java or something else?
      They differ in kind of installed plugins and I would like to test it on my side.

      Cheers,
      Jacek

      1. Hi,

        I am using Spring Tool Suite  version is 3.3.0.RELEASE and build id is 20307091648.

        Thank you Jacek

        1. Hello Arun,

          I tried Atlassian Connector with Spring Tool Suite 3.4.0 (build id: 201310051614) and everything seems to work fine.

          Can you please try to upgrade your installation and try once again? If the error persists can you please paste the full stacktrace (you can find it in the Eclipse log)?

          Cheers,
          Jacek

          1. Hi Jacek,

            I am still getting the same error after upgrading my eclipse to the version mentioned by you.

            The full stack trace in the eclipse log is as below:

            !ENTRY com.atlassian.connector.eclipse.jira.ui 4 0 2013-12-30 09:14:35.750
            !MESSAGE com.sun.jersey.api.client.ClientHandlerException: javax.net.ssl.SSLHandshakeException: sun.security.validator.ValidatorException: PKIX path building failed: sun.security.provider.certpath.SunCertPathBuilderException: unable to find valid certification path to requested target
            !STACK 0
            com.atlassian.connector.eclipse.internal.jira.core.service.JiraException: com.sun.jersey.api.client.ClientHandlerException: javax.net.ssl.SSLHandshakeException: sun.security.validator.ValidatorException: PKIX path building failed: sun.security.provider.certpath.SunCertPathBuilderException: unable to find valid certification path to requested target
                at com.atlassian.connector.eclipse.internal.jira.core.service.rest.JiraRestClientAdapter.call(JiraRestClientAdapter.java:765)
                at com.atlassian.connector.eclipse.internal.jira.core.service.rest.JiraRestClientAdapter.getSessionInfo(JiraRestClientAdapter.java:372)
                at com.atlassian.connector.eclipse.internal.jira.core.service.JiraClient.getSessionInfo(JiraClient.java:615)
                at com.atlassian.connector.eclipse.internal.jira.core.JiraClientManager.validateConnection(JiraClientManager.java:156)
                at com.atlassian.connector.eclipse.internal.jira.core.JiraClientFactory.validateConnection(JiraClientFactory.java:167)
                at com.atlassian.connector.eclipse.internal.jira.ui.wizards.JiraRepositorySettingsPage$JiraValidator.run(JiraRepositorySettingsPage.java:537)
                at org.eclipse.mylyn.tasks.ui.wizards.AbstractRepositorySettingsPage$29.run(AbstractRepositorySettingsPage.java:1964)
                at org.eclipse.jface.operation.ModalContext$ModalContextThread.run(ModalContext.java:121)
            Caused by: com.atlassian.jira.rest.client.RestClientException: com.sun.jersey.api.client.ClientHandlerException: javax.net.ssl.SSLHandshakeException: sun.security.validator.ValidatorException: PKIX path building failed: sun.security.provider.certpath.SunCertPathBuilderException: unable to find valid certification path to requested target
                at com.atlassian.jira.rest.client.internal.jersey.AbstractJerseyRestClient.invoke(AbstractJerseyRestClient.java:83)
                at com.atlassian.jira.rest.client.internal.jersey.JerseyMetadataRestClient.getSessionInfo(JerseyMetadataRestClient.java:118)
                at com.atlassian.connector.eclipse.internal.jira.core.service.rest.JiraRestClientAdapter$7.call(JiraRestClientAdapter.java:374)
                at com.atlassian.connector.eclipse.internal.jira.core.service.rest.JiraRestClientAdapter$7.call(JiraRestClientAdapter.java:1)
                at com.atlassian.connector.eclipse.internal.jira.core.service.rest.JiraRestClientAdapter.call(JiraRestClientAdapter.java:730)
                ... 7 more
            Caused by: com.sun.jersey.api.client.ClientHandlerException: javax.net.ssl.SSLHandshakeException: sun.security.validator.ValidatorException: PKIX path building failed: sun.security.provider.certpath.SunCertPathBuilderException: unable to find valid certification path to requested target
                at com.sun.jersey.client.apache.DefaultApacheHttpMethodExecutor.executeMethod(DefaultApacheHttpMethodExecutor.java:213)
                at com.sun.jersey.client.apache.ApacheHttpClientHandler.handle(ApacheHttpClientHandler.java:175)
                at com.sun.jersey.api.client.Client.handle(Client.java:629)
                at com.sun.jersey.api.client.WebResource.handle(WebResource.java:601)
                at com.sun.jersey.api.client.WebResource.get(WebResource.java:187)
                at com.atlassian.jira.rest.client.internal.jersey.JerseyMetadataRestClient$2.call(JerseyMetadataRestClient.java:125)
                at com.atlassian.jira.rest.client.internal.jersey.JerseyMetadataRestClient$2.call(JerseyMetadataRestClient.java:118)
                at com.atlassian.jira.rest.client.internal.jersey.AbstractJerseyRestClient.invoke(AbstractJerseyRestClient.java:62)
                ... 11 more
            Caused by: javax.net.ssl.SSLHandshakeException: sun.security.validator.ValidatorException: PKIX path building failed: sun.security.provider.certpath.SunCertPathBuilderException: unable to find valid certification path to requested target
                at sun.security.ssl.Alerts.getSSLException(Alerts.java:192)
                at sun.security.ssl.SSLSocketImpl.fatal(SSLSocketImpl.java:1884)
                at sun.security.ssl.Handshaker.fatalSE(Handshaker.java:276)
                at sun.security.ssl.Handshaker.fatalSE(Handshaker.java:270)
                at sun.security.ssl.ClientHandshaker.serverCertificate(ClientHandshaker.java:1341)
                at sun.security.ssl.ClientHandshaker.processMessage(ClientHandshaker.java:153)
                at sun.security.ssl.Handshaker.processLoop(Handshaker.java:868)
                at sun.security.ssl.Handshaker.process_record(Handshaker.java:804)
                at sun.security.ssl.SSLSocketImpl.readRecord(SSLSocketImpl.java:1016)
                at sun.security.ssl.SSLSocketImpl.performInitialHandshake(SSLSocketImpl.java:1312)
                at sun.security.ssl.SSLSocketImpl.writeRecord(SSLSocketImpl.java:702)
                at sun.security.ssl.AppOutputStream.write(AppOutputStream.java:122)
                at java.io.BufferedOutputStream.flushBuffer(BufferedOutputStream.java:82)
                at java.io.BufferedOutputStream.flush(BufferedOutputStream.java:140)
                at org.apache.commons.httpclient.HttpConnection.flushRequestOutputStream(HttpConnection.java:828)
                at org.apache.commons.httpclient.MultiThreadedHttpConnectionManager$HttpConnectionAdapter.flushRequestOutputStream(MultiThreadedHttpConnectionManager.java:1565)
                at org.apache.commons.httpclient.HttpMethodBase.writeRequest(HttpMethodBase.java:2116)
                at org.apache.commons.httpclient.HttpMethodBase.execute(HttpMethodBase.java:1096)
                at org.apache.commons.httpclient.HttpMethodDirector.executeWithRetry(HttpMethodDirector.java:398)
                at org.apache.commons.httpclient.HttpMethodDirector.executeMethod(HttpMethodDirector.java:171)
                at org.apache.commons.httpclient.HttpClient.executeMethod(HttpClient.java:397)
                at com.sun.jersey.client.apache.DefaultApacheHttpMethodExecutor.executeMethod(DefaultApacheHttpMethodExecutor.java:210)
                ... 18 more
            Caused by: sun.security.validator.ValidatorException: PKIX path building failed: sun.security.provider.certpath.SunCertPathBuilderException: unable to find valid certification path to requested target
                at sun.security.validator.PKIXValidator.doBuild(PKIXValidator.java:385)
                at sun.security.validator.PKIXValidator.engineValidate(PKIXValidator.java:292)
                at sun.security.validator.Validator.validate(Validator.java:260)
                at sun.security.ssl.X509TrustManagerImpl.validate(X509TrustManagerImpl.java:326)
                at sun.security.ssl.X509TrustManagerImpl.checkTrusted(X509TrustManagerImpl.java:231)
                at sun.security.ssl.X509TrustManagerImpl.checkServerTrusted(X509TrustManagerImpl.java:126)
                at sun.security.ssl.ClientHandshaker.serverCertificate(ClientHandshaker.java:1323)
                ... 35 more
            Caused by: sun.security.provider.certpath.SunCertPathBuilderException: unable to find valid certification path to requested target
                at sun.security.provider.certpath.SunCertPathBuilder.engineBuild(SunCertPathBuilder.java:196)
                at java.security.cert.CertPathBuilder.build(CertPathBuilder.java:268)
                at sun.security.validator.PKIXValidator.doBuild(PKIXValidator.java:380)
                ... 41 more

             

            1. Hi Arun,

              From what I can see that's a different error (there is no more java.lang.ClassNotFoundException).

              The stacktrace suggests that your JIRA ssl certificate is not trusted. In this case you should download the certificate and install in your local java keystore. Please take a look at following issue for more details and instruction: https://ecosystem.atlassian.net/browse/PLE-1430

              Cheers,
              Jacek

  56. Anonymous

    Hi, I'm trying an offline install using the e3.7-site-all.zip, and it is complaining about javax.activation_1.1.0.v201108011116.jar and org.apache.commons.codec_1.3.0.v201101211617.jar not found in the zip archive.  And, in fact, there is only the 2008 versions of these libraries in the zip archive.  It appears the dependencies should be updated, or the jar files within the zip archive.

    1. Hi,

      Thank you for the report. What is your Eclipse version and package?

      Thanks.

      1. My Eclipse version is Kepler (4.3 SR1), build 20130919-0819.  Thanks.

        1. Hi Barry,

          Please also let me know the package. Is it Standard, Java, C++, JavaEE or something else?
          They differ in content and missing libraries problem may depend on the Eclipse package.

          Thanks,
          Jacek

          1. Hi Jacek,

            It is the CDT (C++). 

            Thanks.

    2. Hi,

      I have just tried e3.7-site-all.zip with Eclipse IDE for C/C++ Kepler SR1 (build 20130919-0819) and the the installation has gone smoothly.
      I can see that the zipped site contains 2010 versions of the mentioned libraries and the Eclipse contains newer versions.

      Have you grabbed the fresh site zip (what is the version of Atlassian Connector you try to install)? What is your OS?

      I also suggest to perform installation on clear Eclipse. Maybe the problem is related to conflicting dependencies with other plugins.

      Cheers,
      Jacek

      1. Hi Jacek,

        Yes, I performed the installation on a clear Eclipse.  The offline install zip will work on a machine connected to the internet, where it can download the older versions of the plugins that are specified in the Atlassian dependencies.  However, I'm using the offline zip on a machine that is not connected to the internet... hence the offline install process.  The dependencies in the Atlassian connector need to match what is provided in the zip file for an unconnected install to function properly, correct?

        Thanks,

        Barry

        1. Hi Barry,

          I managed to reproduce the issue. Indeed the installation failed without internet connection.  And you are right that Eclipse downloads missing dependencies even if "contact all update sites" option is disabled which is slightly confusing.
          Even more interesting is that Atlassian Connector does not depend on any particular version of the problematic dependencies.

          Overall I fixed the problem with:

          • removing javax.activation and all related plugins (they are not used any more)
          • bumped org.apache.commons.codec to the newer package (version is still the same)
          • removed SOAP internals completely and removed dependency to Mylyn Soap

          Everything works fine on my side with nightly zipped update site. It is available at http://update.atlassian.com/atlassian-eclipse-plugin/rest/nightly/e3.7-site-all.zip

          Can you please try it and let me know if everything is OK?

          Thanks,
          Jacek

          1. Hi Jacek,

            The plugin installs without issue now, thanks so much.  Of note, I'm getting an INFO::Logging to STDERR via org.mortbay.log.StdErrLog message on the console now that maybe is left over from some of your debugging activities?  I am also connecting successfully to my JIRA repository (can see the saved filters and such), but the plugin does not display the tasks for some reason.  I'll try the install again with a clean Eclipse to be sure, and let you know if there is still a problem.

             

            Thanks,

            Barry

          2. Ok, just tried again with a fresh Eclipse, and it does appear that something is broken in the nightly outside of the connector install.  If you can flow that information to someone, I'll give it a couple days and pull from the nightly again and give it another shot. 

            Thanks,
            Barry

            1. Hey Barry,

              I have just tried clean Eclipse and nightly zipped site offline installation. The installation went smooth and I can successfully connect to and work with local JIRA installation (still being offline).

              Can you elaborate what do you mean by "the plugin does not display the tasks for some reason"?

              What query have you defined? Was the query executed successfully? Is there anything in Eclipse log? Can you see the query in the Mylyn Tasks List view?

              You can open support request if you would like to keep this conversation private: https://support.atlassian.com/browse/ECSP

              Cheers,
              Jacek

  57. Hi 

    I'm try to connect SSL JIRA with Kepler SR2 by using nightly build Connector.

    When I'm try to connect, I'm getting following error

     com.sun.jersey.api.client.ClientHandlerException: javax.net.ssl.SSLHandshakeException:

    sun.security.validator.ValidatorException:

    Is this plugin support SSL? or just HTTP? 

    1. We definitely support SSL. One of the reasons of this issue might be that the server is using self-signed certificate or the certificate cannot be validated against known path.

      You may try to add certificate to your local java keystore. Please see following issue for more details: PLE-1430 - SSLHandshakeException - Allow to accept SSL certificates not found in certification path Open

      Cheers,
      Jacek

  58. Cannot install Atlassian Eclipse Connector in Eclipse 4.4 :

    Cannot complete the install because one or more required items could not be found.

    Software being installed: Atlassian Connector for Eclipse 3.2.2.v20130909 (com.atlassian.connector.eclipse.feature.group 3.2.2.v20130909)
    Missing requirement: Atlassian Connector Commons 3.2.2.v20130909 (com.atlassian.connector.commons.feature.group 3.2.2.v20130909) requires 'org.apache.commons.codec [1.3.0.v201101211617]' but it could not be found
    Cannot satisfy dependency:
    From: Atlassian Connector for Eclipse 3.2.2.v20130909 (com.atlassian.connector.eclipse.feature.group 3.2.2.v20130909)
    To: com.atlassian.connector.commons.feature.group [3.2.2.v20130909]

    1. Also I cannot "Report a Bug" (below) because it requires extranet.atlassian.com login and there's no Sign Up link.

        1. Ok, so how do I report a bug for the confluence.atlassian.com site itself??

          since "Report a Bug" link below is incorrect

          1. The "Report a bug" link in the footer is for Confluence. I can see it links to https://jira.atlassian.com/browse/CONF which seems to be correct (note it is jira.atlassian.com which is public).

            1. No, they link to studio.atlassian.com :

              1. Where is this link located? Can you paste a screenshot?

                Thanks,
                Jacek

                  1. I was looking at the tiny grey link in the page footer and did not see this big blue button (smile)

                    I have asked for an upgrade.

                    Thanks,
                    Jacek

    2. Hi,

      Please try the latest nightly build with Eclipse 4.4: http://update.atlassian.com/atlassian-eclipse-plugin/rest/nightly/e3.7

      We are working on the update and final release.

      Thanks,
      Jacek