Documentation for JIRA 6.4 (This documentation includes the project navigation sidebar). Not using this? See below:
(JIRA 6.4 without sidebar documentation | JIRA 6.3.x documentation | JIRA Cloud documentation | earlier versions of JIRA)

Skip to end of metadata
Go to start of metadata

This guide describes how to install a new JIRA installation on Linux using the automated 'Linux Installer'. If you are upgrading JIRA, please refer to the Upgrading JIRA guide.

(info) You can also install JIRA from a 'zip' archive — see Installing JIRA from an Archive File on Windows, Linux or Solaris for details. This is useful if you want JIRA to use a pre-existing supported Java platform, since the Linux Installer installs its own JRE to run JIRA.

It is possible that any anti-virus or other Internet security tools installed on your Linux operating system may interfere with the JIRA installation process and prevent the process from completing successfully. If you experience or anticipate experiencing such an issue with your anti-virus/Internet security tool, disable this tool first before proceeding with the JIRA installation.

There are two ways to install JIRA using the Linux Installer:

On this page:

Using the Console Wizard

Use the console wizard if you are installing JIRA on your server for the first time or you wish to specify your installation options.

If you have previously installed JIRA using the installation wizard and wish to re-install JIRA again with the same installation options, you can re-install JIRA in 'unattended mode' without any user input required (see below for details).

1. Download and Install the JIRA 'Linux Installer'

(tick) If you execute the Linux Installer with 'root' user privileges, the installer will create a dedicated user account for JIRA. You can also execute the Linux Installer without 'root' user privileges, but your installation options will be much more limited and the installer will not be able to create a dedicated user account for running JIRA. To run JIRA as a service, the Linux Installer must be executed with 'root' user privileges.

  1. Download the appropriate JIRA 'Linux 64-bit / 32-bit Installer' (.bin) file from the JIRA Download page.
    (info) Please Note:
    • To access the 32-bit installer, you may need to click the 'Show all' link on the 'JIRA Download' page to access the other installation packages.
    • The difference between the 64-bit / 32-bit .bin installers relates to their bundled Java platforms that run JIRA. Bear in mind that a JIRA installation installed using the 64-bit installer may require additional memory (to run at a similar level of performance) to a JIRA installation installed using the 32-bit installer. This is because a 64-bit Java platform's object references are twice the size as those for a 32-bit Java platform.
  2. Open a Linux console and change directory (cd) to the '.bin' file's directory.
    (warning) If the '.bin' file is not executable after downloading it, make it executable, for example:
    chmod a+x atlassian-jira-X.Y.bin
    (where X.Y represents your version of JIRA)
  3. Execute the '.bin' file to start the console wizard.
  4. When prompted to choose between 'Express Install', 'Custom Install' or 'Upgrade an existing JIRA installation', choose either the 'Express Install' or 'Custom Install' options:
    • Express Install— If you choose this option, JIRA will be installed with default settings which are shown in the next step of the console wizard.
      (info) Please Note:
      • If you are running the installer with 'root' user privileges, JIRA will be installed as a service.
      • If you want to customize any of these options:
        1. Enter 'e' to exit the console wizard.
        2. Execute the console wizard again (step 3 above).
        3. Choose the 'Custom Install' option instead.
    • Custom Install — If you choose this option, JIRA will prompt you to specify the following options (which are presented during subsequent steps of the console wizard and pre-populated with default values):
      • The 'Destination Directory' in which to install JIRA.
      • The JIRA Home directory (which must be unique for each JIRA installation).
      • The TCP ports (i.e. an HTTP and a Control port) that JIRA will run through.
      • If you are running the installer with 'root' user privileges, you will be prompted to 'Run JIRA as a service' (recommended). You can also do this manually later, as described in Starting JIRA Automatically on Linux.
  5. The console wizard will install JIRA onto your operating system and will start JIRA automatically when the wizard finishes.

(info) Please Note:

  • If you executed the Linux Installer with 'root' user privileges, the Linux Installer creates a dedicated Linux user account with username 'jira' and no password, which is used to run JIRA. This account has only:
  • The bundled installer expects the 'root' user to have have the default umask (0022 or 002), if this is not set it can cause problems with the install as per  JRA-32435 - JIRA Linux Installer does not set files with correct permissions when a non-default umask is used Verified . Please ensure this is set prior to installation.
  • If you executed the Linux Installer without 'root' user privileges, be aware that JIRA can still be run with 'root' privileges. However, to protect the security of your operating system, this is not recommended.
  • Depending on how big the JIRA instance may become, you may need to increase the maximum number of files available on the operating system. This is further covered in our Loss of Functionality due to Too Many Open Files Error KB - please review it for further information.

2. Start JIRA

If JIRA is not already started, you can start JIRA using the appropriate command at the Linux console.

Once JIRA is started, you can access JIRA from a browser on any computer with network access to your JIRA server.

2.1 Starting and Stopping JIRA manually

If JIRA was installed as a user with 'root' privileges, use the JIRA service in the Linux console. These commands will need to be executed as a user with 'root' privileges.

  • service jira start (to start JIRA)
  • service jira stop (to stop JIRA)

If JIRA was not installed as a user with 'root' privileges, in the Linux console, enter the bin subdirectory of your JIRA installation directory and execute the appropriate file:

If the below commands are used as a user with 'root' privileges, and JIRA was installed as another user (for example jira) it can cause permissions problems as detailed in JIRA Generates a FileNotFoundException due to Permission denied.

  • (to start JIRA)
  • (to stop JIRA)

JIRA will be ready to access (from a browser window) when the following message appears in the application's log file:

2.2 Accessing JIRA from a Browser

You can access JIRA from any computer with network access to your JIRA server by opening a supported web browser on the computer and visiting this URL:

  • http://<computer_name_or_IP_address>:<HTTP_port_number>


  • <computer_name_or_IP_address> is the name or IP address of the computer on which JIRA is installed and
  • <HTTP_port_number> is the HTTP port number specified when you installed JIRA (above).

(info) Please Note:

3. Run the Setup Wizard

See Running the Setup Wizard.

4. Next Steps

Performing an Unattended Installation

If you have previously installed JIRA using the console wizard (above), you can use a configuration file from this JIRA installation (called response.varfile) to re-install JIRA in 'unattended mode' without any user input required.

Installing JIRA in unattended mode saves you time if your previous JIRA installation was used for testing purposes and you need to install JIRA on multiple server machines based on the same configuration.

(warning) Please Note:

  • The response.varfile file contains the options specified during the installation wizard steps of your previous JIRA installation. Hence, do not uninstall your previous JIRA installation just yet.
  • If you intend to modify the response.varfile file, please ensure all directory paths specified are absolute, for example, sys.installationDir=/opt/atlassian/jira
    Unattended installations will fail if any relative directory paths have been specified in this file.

Download and Run the JIRA 'Linux Installer' in Unattended Mode

  1. Download the JIRA 'Linux Installer' (.bin) file from the JIRA Download Center to a suitable location.
  2. Open a Linux console.
  3. Copy (cp) the file .install4j/response.varfile located in your previous JIRA installation directory, to the same location as the downloaded 'Linux Installer' file.
    (info) You can uninstall your previous JIRA installation after this step. Save your response.varfile if you need to install JIRA on multiple machines.
  4. Change directory (cd) to the location of the 'Linux Installer' file and execute the following command:

    atlassian-jira-X.Y.bin -q -varfile response.varfile


    • X.Y — refers to the version of JIRA you are about to install.
    • -q — instructs the installer to operate in unattended mode (i.e. 'quietly').
    • -varfile response.varfile — specifies the configuration file containing the configuration options used by the installer. The location and name of the configuration file should be specified after the -varfileoption.

  5. JIRA will start automatically when the silent installation finishes. Continue from step 2 Starting JIRA (above).


  1. Anonymous

    One thing that may not be not readily apparent in "2 Set JIRA Home" (or either of the TWO pages it redirects you to) to a total n00b (i.e., what I was 2 days ago) is that $JIRA_HOME, _UNLIKE TOMCAT AND JDK_, should not be set to the atlassian standalone directory itself. Rather, you should create a home directory inside of the atlassian-jira folder to serve as $JIRA_HOME.

    Also, you'd think that a company that sells an SSO solution would figure out how to integrate their different instances so that the same account I use for I can use for and Just sayin'.

    1. Anonymous

      Make that inside the atlassian standalone directory, not the atlassian-jira subdirectory. Else you get a nice:

      Configured jira.home '/home/master/atlassian-jira-4.3.2-standalone/atlassian-jira/home' must not be a directory within the webapp servlet path '/home/master/atlassian-jira-4.3.2-standalone/atlassian-jira'

      in your catalina.out

    2. Also, you'd think that a company that sells an SSO solution would figure out how to integrate their different instances

      This is on purpose, to keep your payment and account data separate from JAC access.

  2. Anonymous

    What is the difference between "" and ""?

    1. Hi there, is simply a 'wrapper' script for the script (i.e. runs (The same principle applies to the start-jira.bat and startup.bat scripts for Windows OS's.) was created to standardise the start-up scripts for Atlassian applications, which are now following the naming format — start-<atlassian-application-name>.sh

      We recommend using the start-jira scripts to start JIRA instead of startup.


  3. Anonymous


      im a newbie in jira but i just follow the tutorial on how to was successfully install. i can now access it in my browser and i change the port question is afetr 2 day on running i can no longer login using my administrator wondering what keeps on loading..maybe somebody here can help my problem..thanks

    1. Hi there,

      Thanks for your feedback and glad to hear you got JIRA up and running.

      As for the issue with being unable to log in, it's difficult to determine the exact cause of the problem without further investigation.

      I'd recommend you contact customer support by clicking the Get Support 'button' link below.


  4. Anonymous

    I tried the standalone installation as root, and it all appeared to run correctly. However, the jira user never got created and all the files in the installation are owned by root. I selected the default settings for everything.

    Any idea where I should look first to fathom out what went wrong?

    1. Hello there,

      Could you please confirm whether or not you did use the Linux Installer (.bin) file to install JIRA on Linux?

      If so, could you please submit a support request by clicking the 'Get Support' button at the end of this page.

      On the support ticket, could you also indicate what type and version of Linux you were installing JIRA onto as this may help the Support Team with their investigations.

      Kind regards,

    2. Anonymous

      I ran into the same issue. I found the bin/ script and ran it separately (output is below), which revealed that the script is using a useradd option that's not supported in my version of Linux, which is: SUSE Linux Enterprise Server 11 (x86_64); VERSION = 11; PATCHLEVEL = 1

      # /opt/atlassian/jira/bin/ -d /var/atlassian/application-data/jira -i /opt/atlassian/JIRA
      useradd: invalid option -- 'K'
      Try `useradd --help' or `useradd --usage' for more information.
      chown: invalid user: `jira'
      chown: invalid user: `jira'
      chown: invalid user: `jira'
      chown: invalid user: `jira'
      This command will fix the script:
      sed -ie 's~ -K UMASK=0077~~' /opt/atlassian/jira/bin/
      1. Thanks for investigating and figuring out what the problem is. We will track this bug under and will try to fix it as soon as possible.

        Meanwhile the workaround is to:

        • add a new user called jira to the system
        • change the permissions on the installation directory so that it is readable by jira (for security reasons only some subdirs should be writable by jira 
        • change the permissions of  work/ temp/ logs/ so that it is writable(owned) by jira
        • change the permissions of the home directory to be writable(owned) by jira
      2. This is also a problem for the Confluence installer. Please see: CONF-23686

  5. Anonymous

    I had same behaviour.


    Using Jira 4.4 64-bit binary - OpenSuSE 11.4

    Installation appears to have been successful (at least that's what the installer tells me).


    the given web address link doesn't work, all of the installed files are owned by root, and no JIRA user was created.

  6. Anonymous

    Fixed Linux installation:

    OpenSuse 11.4


    Created new group "jira" (using YaST)

    Created new user "jira" (using YaST)


    chown -R /opt/atlassian/jira jira

    chown R /var/atlassian/application(dash)data/jira JIRA


    cd /opt/atlassian/jira/bin


  7. Took virtually no effort to install and get running on CentOS 6

    Simple wget to get the binary, ran the binary, used defaults and bam ... I am in business.

    The way things should be for all software.

  8. On CentOS 5.7, I could not start Jira with script:

    # ./

     To run JIRA in the foreground, start the server with -fg

     Server startup logs are located in /opt/atlassian/jira/bin/logs/catalina.out

    executing using dedicated user: jira

    ./ line 64: /opt/atlassian/jira/bin/ Permission denied

    ./ line 64: exec: /opt/atlassian/jira/bin/ cannot execute: Permission denied

    However, worked fine.


    1. Hi Simon,

      Sounds like the file permissions were not set correctly. The installer should set the correct permissions as described here . It is possible that something went wrong during the installation and the permissions where not set. In particular it looks like /opt/atlassian/jira/bin/ are not readable by user jira (it should be owned by root but readable by jira just like most of the installation).


      By executing directly you run the process as the current logged in user. In your case it is root and it is not advisable from a security point of view. If you change the permissions of you installation so that

      • everything is owned by root but readable by jira
      • sub-directories log temp and work owned and writable by jira

      then should start working. Please create a support issue if you hit nay problems.

  9. Anonymous

    Trying the self-installed on ubuntu Linux.. md5sums check out

    sudo ./atlassian-jira-5.0.1-x64.bin
    Unpacking JRE ...
    Starting Installer ...
    /path/to/atlassian-jira-5.0.1-x64.bin.774.dir/jre/bin/java: 1: Syntax error: "(" unexpected


    any suggestions/thoughts?

    1. Hi, can you please contact support and we will help you out. I suspect some variation of your env makes it fail (shell, bitness or something else).

    2. Anonymous

      I have the same Problem (Debian Linux Linux 2.6.32-5-686 on i686):

      sh ./atlassian-jira-5.0.4-x64.bin
      Unpacking JRE ...
      Starting Installer ...
      /tmp/atlassian-jira-5.0.4-x64.bin.4932.dir/jre/bin/java: 1: Syntax error: "(" unexpected
      java -version
      java version "1.7.0_03-icedtea"
      OpenJDK Runtime Environment (IcedTea7 2.1) (7~u3-2.1-3)
      OpenJDK Client VM (build 22.0-b10, mixed mode, sharing)



      1. Hi,

        Just try atlassian-jira-5.0.4-x32.bin instead of atlassian-jira-5.0.4-x64.bin and it should work.

  10. Anonymous

    After working for two days to resolve the right way to do things (the only clue seems to be comments on this page and the instructions on Starting JIRA Automatically on Linux), I was finally able to get my Jira instance working and started automatically on Ubuntu 10.04 LTS.

    The problems that I encountered seemed to be related to the umask I have setup on my system (0077) and I could have made the installation directory owned by the jira, but there has been explicit direction not to do that for security reasons. Here is what I did to get the system working and a quick explanation of each.

    1. chmod a+x /opt/atlassian/jira/bin/*.sh
      1. contains 'chmod +x "$install_dir"/bin/*.sh'. Using +x instead of a+x incorporates the use of the umask according to the manpage.
    2. chmod -R go+rX /opt/atlassian
      1.  to allow to set CATALINA_HOME as needed. This change should probably be added to
    3. chmod -R go+rX /var/atlassian
      1. to allow the home directory to be accessed. Perhaps it shouldn't go all the way down, but certainly the jira user needs to be able to navigate to the home directory.
  11. Anonymous

    I have start service,but i never see "you can access JIRA through your browser".

    [root@localhost bin]# ./

    To run JIRA in the foreground, start the server with -fg

    Server startup logs are located in /usr/local/jira/bin/logs/catalina.out
    executing using dedicated user: jira


    __ __ __ _ __
    \ \/ /___ __ __ / /_ ____ __ _____ (_)___________ _____ _____/ /
    \ / __ \/ / / / / __ \/ __ `/ | / / _ \ / / ___/ ___/ / / / _ \/ ___/ /
    / / /_/ / /_/ / / / / / /_/ /| |/ / __/ / (__ |__ ) /_/ / __(__ )_/
    /_/\____/\__,_/ /_/ /_/\__,_/ |___/\___/ /_/____/____/\__,_/\___/____(_)

    JIRA Standalone Edition
    Version : 4.4.1

    Detecting JVM PermGen support...
    PermGen switch is supported. Setting to 256m

    If you encounter issues starting or stopping JIRA Standalone Edition, please see the Troubleshooting guide at

    Using CATALINA_BASE: /usr/local/jira
    Using CATALINA_HOME: /usr/local/jira
    Using CATALINA_TMPDIR: /usr/local/jira/temp
    Using JRE_HOME: /usr/local/jira/jre/
    Using CLASSPATH: /usr/local/jira/bin/bootstrap.jar
    Using CATALINA_PID: /usr/local/jira/work/


    Please help.

    1. Hi Anonymous,

      the log file you posted doesn't have any errors, so it is difficult to see what's happening. It usually takes a bit of time for a JIRA instance to start up but it should not take longer than 1 min, if you waited that long and JIRA had not started then there must be some problem. Can you please contact support and we will help you to diagnose what went wrong.

  12. Anonymous


    when I execute the atlassian-jira-5.1-x32.bin as root I get the error:
    atlassian-jira-5.1-x32.bin.1847.dir/jre/bin/java: No such file or directory.

    Any advice what I am doing wrong?

    Thank you.

    1. Hi, what else did it print out? It looks like the archive didn't get extracted correctly.


      1. Anonymous

        Unpacking JRE ...
        Starting Installer ...
        ./atlassian-jira-5.1.2-x32.bin: line 466: /srv/ftp/ftp01/atlassian-jira-5.1.2-x3 2.bin.19958.dir/jre/bin/java: No such file or directory

        1. Hi, looks like some environment problem, perhaps file permissions, but it is difficult to see what's going from those output lines. Can you please contact support and we will help you to figure out what the problem is. 


          1. Anonymous

            The x64-Version works fine so I dont think this has something to do with file permissions.

  13. I have a project with more that 100,000 issues with attachments and since ext4 cannot hold more than 65000 subdirectories, am planning to use RHEL 6 with XFS (file system) which has practically no subdirectory limit.

    Any comments or suggestions.





  14. Anonymous

    after installing JIRA, it runs for about a minute, using more and more memory until finally it crashes.  i'm on CentOS 5.8  Here's the output from top just before the crash:

    top - 20:17:24 up 206 days, 19:49,  3 users,  load average: 2.54, 1.16, 0.70
    Tasks:  56 total,   2 running,  54 sleeping,   0 stopped,   0 zombie
    Cpu(s): 92.6%us,  7.4%sy,  0.0%ni,  0.0%id,  0.0%wa,  0.0%hi,  0.0%si,  0.0%st
    Mem:    524288k total,   448736k used,    75552k free,        0k buffers
    Swap:        0k total,        0k used,        0k free,        0k cached
      PID USER      PR  NI  VIRT  RES  SHR S %CPU %MEM    TIME+  COMMAND                      
     9474 jira      25   0 1166m 300m  21m S 54.3 58.6   0:50.74 java                   


    1. Hi, it is impossible to diagnose what's going on just from the top output, can you please contact support and we will help you out.

  15. Anonymous

    I got this in log/catalina.log


    INFO: The APR based Apache Tomcat Native library which allows optimal performance in production environments was not found on the java.library.path: /opt/atlassian/jira/jre/lib/amd64/server:/opt/atlassian/jira/jre/lib/amd64:/opt/atlassian/jira/jre/../lib/amd64:/bin/atlassian-jira-5.1.4-x64.bin.24322.dir/jre/lib/amd64/server:/bin/atlassian-jira-5.1.4-x64.bin.24322.dir/jre/lib/amd64:/bin/atlassian-jira-5.1.4-x64.bin.24322.dir/jre/../lib/amd64:/usr/java/packages/lib/amd64:/usr/lib64:/lib64:/lib:/usr/lib

    Any advice...Pls

  16. Anonymous


    install was successfull on Centos 6.  Server starts with no errors, checked catalina.out shows the following.

    INFO: Starting Coyote HTTP/1.1 on http-8080

    Oct 2, 2012 6:23:57 PM org.apache.catalina.startup.Catalina start

    INFO: Server startup in 13568 ms


    going to http://server:8080 and I get "Browser could not connect errors".  Telnet to the port and the port opens but can't get anykind of response from server.  Have to kill telnet session.

    1. Deadlock? Does restarting help? If everything fails please contact support and we will help you to debug.

  17. Got a very frustrating issue on debian squeeze 64-bit. I installed using atlassian-jira-5.1.6-x64.bin, using the default settings except that I moved from /var/atlassian/application-data/jira to /opt/atlassian/application-data/jira.

    I had to run the following manually:

    $ chown -R jira:jira /opt/atlassian/jira

    $ chown -R  jira:jira /opt/atlassian/application-data/jira

    I also had to update your script:

    PRG="$(readlink -f $0)"

    Then I went to start the service:

    $ service jira start
    To run JIRA in the foreground, start the server with -fg
    executing using dedicated user: jira
    sh: /opt/atlassian/jira/bin/ Permission denied

    Tried to run this manually:

    $ ./ -fg
    executing using dedicated user: jira
    bash: /opt/atlassian/jira/bin/ Permission denied


    $ ./
    .... .NMMMD. ...
    .8MMM. $MMN,..~MMMO.
    .?MMM. .MMM?.
    Atlassian JIRA
    Version : 5.1.6
    Detecting JVM PermGen support...
    PermGen switch is supported. Setting to 256m
    If you encounter issues starting or stopping JIRA, please see the Troubleshooting guide at

    Server startup logs are located in /opt/atlassian/jira/logs/catalina.out
    Using CATALINA_BASE: /opt/atlassian/jira
    Using CATALINA_HOME: /opt/atlassian/jira
    Using CATALINA_TMPDIR: /opt/atlassian/jira/temp
    Using JRE_HOME: /opt/atlassian/jira/jre/
    Using CLASSPATH: /opt/atlassian/jira/bin/bootstrap.jar
    Using CATALINA_PID: /opt/atlassian/jira/work/


    Yay seems to have worked!  Except ...

    $ ps aux | grep jira
    root 15643 0.0 0.1 8788 844 pts/6 S+ 15:12 0:00 grep --color JIRA

    And nothing in the logs explains where it went.


    1. Hi Kevin,

      why did you manually run chown commands? The installer already does all the necessary security steps and it is on purpose that the installation directory is not owned by jira user but only readable by that user (with some exceptions). Explanation can be found here

      In any case if you have trouble installing can you please contact support.


  18. Before chowning things, the jira user did not have read, write, or execute permissions on any file in the directory; I got permission denied from the outset.  Also, this is a security concern that frankly does not bother me; I would rather have it running and be slightly insecure (which is the result of the chown I performed), than to have it fail to run.  I will contact support, however.

  19. Anonymous

    Sarath -  Can u help me out ?

     How to change the port 8080 to default 80..................

  20. Anonymous

    i install in a subfolder.

    example in JIRA under public_html

    my URL should be

    how to call the port of 8080 if is under the subfolder??

    1. Anonymous

  21. Anonymous


    due to company internal restrictions on accountnames I won't be allowed to create an user "jira". Is there a way to change the username?




    1. Hi Chris, 

      If you're using the compressed version of JIRA for the standalone installation, the user creation is not needed, you can start up JIRA with what ever user you wanted. 



  22. I'm installing on CentOS 6.4, running as root.  The problem is that the installer does not create a dedicated user, as it says in the documentation above.  However, it tries to use the dedicated user when try to start it.  Therefore, it will not start.


    What am I missing?

    1. Hi David

      The installer supposed to create the dedicated user - there must be something going wrong with it. Can you please contact support and we will help you out. 

      As a quick workaround you can try creating the dedicated user 'jira' manually to get the installation working.


  23. Anonymous

    I tried to install JIRA onto Debian 7 (wheezy) but I got weird  "Unable to esablish a connection with the database. (Unexpected exception encountered during query.)" errors with Debians packaged mysql jdbc connector (5.1.16). I upgraded JDBC connector to the latest from MySQL website (.26) and it worked fine.

  24. Hello,

    Tried installing on Ubuntu 13.04, installer fails :

    >>> ./atlassian-jira-6.1.4-x64.bin.1
    Unpacking JRE ...
    Starting Installer ...
    /root/atlassian-jira-6.1.4-x64.bin.1.12473.dir/jre/bin/java: 1: /root/atlassian-jira-6.1.4-x64.bin.1.12473.dir/jre/bin/java: Syntax error: end of file unexpected (expecting ")")

    >>> uname -a

    Linux host 3.8.0-31-generic #46-Ubuntu SMP Tue Sep 10 19:56:49 UTC 2013 i686 athlon i686 GNU/Linux

    >>> md5sum atlassian-jira-6.1.4-x64.bin.1

    c6476c12221360878e410f6a435ff697 atlassian-jira-6.1.4-x64.bin.1

    (Reported checksum on website md5 c6476c12221360878e410f6a435ff697)

    Any ideas what might be wrong ?



    1. Hi Jasin, 

      Looks like you are using 64bit installer on 32bit system. Please download 32bit installer and it should fix your problem.

  25. hi please help me ..when JIRA setup its asked to chose external step 2 i chosen was asking jdbc.mysql connector to download jdbc.myql .driver using centos console mode...please helpp me how to instlal and how to configure 

    i need to work hlep

  26. MySQL JDBC connector is already available in the classpath (<JIRA INSTALLATION DIR>/lib)

  27. Check if the file exist,

    If not, download it and place it there (

    Restart your JIRA installation and it will proceed to connecting to the DB itself

  28. Embarrassingly, I've accidentally deleted the default 'jira' user created by the LInux installation script and as such JIRA will no longer run properly. I recreated the JIRA user but Ubuntu won't let me (in an obvious manner) re-create the user with no password.

    What steps can I use to recreate the user initially created by the Linux installer?

    Thanks and Regards,

    1. Jeffery, this is the script we use to create Confluence User (JIRA user will be the same but different name):

      You can see the main line there is

      useradd "$username" -c "Atlassian Confluence" -K UMASK=0077

      plus we also adjust permissions for some of the directories.