404 Searching for Request Types in Help Center
Symptoms
Searching for a request type in the Help Center of a Service Management Customer Portal doesn't find the request types with the keyword. The F12 Developer tools of the browser shows a 404 response:
Diagnosis
- If there're linked Confluence Knowledge Bases, the Confluence pages can still be found with the same keyword normally
- From Manage add-ons -> All add-ons, Service Management Search Plugin is Disabled or not all of its modules is enabled
This SQL query:
select * from pluginstate where pluginkey like '%servicedesk-search%';
shows that the plugin is Disabled in the database:
pluginkey pluginenabled com.atlassian.servicedesk.plugins.servicedesk-search-plugin false
Cause
Service Management Search Plugin must be enabled with all modules for the search function in Help Center to work properly.
Resolution
Enable the plugin by following these steps:
- shut down Jira
run this SQL query to enable the plugin in the database:
DELETE from pluginstate where pluginkey like '%servicedesk-search%';
restart Jira