404 Searching for Request Types in Help Center

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Symptoms

Searching for a request type in the Help Center of a Service Management Customer Portal doesn't find the request types with the keyword. The F12 Developer tools of the browser shows a 404 response:

Diagnosis

  1. If there're linked Confluence Knowledge Bases, the Confluence pages can still be found with the same keyword normally
  2. From Manage add-ons -> All add-ons, Service Management Search Plugin is Disabled or not all of its modules is enabled
  3. This SQL query:

    select * from pluginstate where pluginkey like '%servicedesk-search%';

    shows that the plugin is Disabled in the database:

    pluginkeypluginenabled
    com.atlassian.servicedesk.plugins.servicedesk-search-pluginfalse

Cause

Service Management Search Plugin must be enabled with all modules for the search function in Help Center to work properly.

Resolution

Enable the plugin by following these steps:

  1. shut down Jira
  2. run this SQL query to enable the plugin in the database:

    DELETE from pluginstate where pluginkey like '%servicedesk-search%';
  3. restart Jira

Last modified on Nov 23, 2020

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