Accessing the UPM throws a java.net.UnknownHostException

Platform Notice: Data Center - This article applies to Atlassian products on the Data Center platform.

Note that this knowledge base article was created for the Data Center version of the product. Data Center knowledge base articles for non-Data Center-specific features may also work for Server versions of the product, however they have not been tested. Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.

*Except Fisheye and Crucible

Symptoms

When attempting to use the UPM, a java.net.UnknownHostException is thrown, as in the screenshot below:

Diagnosis

The error occurred in JIRA 4.4.5, using the Universal Plugin Manager v1.4.1. It will likely be present in other versions of JIRA and also the UPM.

Cause

The Universal Plugin Manager is unable to establish an outbound connection to the Atlassian Marketplace. The most likely cause for this is the JIRA instance does not have an outbound connection to the Information Superhighway or is using an internal DNS that does not have plugins.atlassian.com in it.

Resolution

This can be resolved with any of the following:

Last modified on Jan 9, 2025

Was this helpful?

Yes
No
Provide feedback about this article
Powered by Confluence and Scroll Viewport.