After Jira upgrade, Index menu is missing

Platform Notice: Data Center Only - This article only applies to Atlassian products on the Data Center platform.

Note that this KB was created for the Data Center version of the product. Data Center KBs for non-Data-Center-specific features may also work for Server versions of the product, however they have not been tested. Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.

*Except Fisheye and Crucible

Summary

After Jira upgrade, the Index menu is missing from ⚙ > System > Indexing

User was not able to reindex newly upgraded Jira instance, as Index menu is missing.

(Auto-migrated image: description temporarily unavailable)

Environment

Jira Server/Data Center on any version from 8.13.0.

Diagnosis

  • Check that Secure Admin plugin is installed in the Jira application (in the page ⚙ > Manage Apps > Manage Apps)

  • It this add-on is installed, try to disable this add-on and check if the issue goes away.

Cause

The Secure Admin plugin is causing this issue. 

Solution

Disable the Secure Admin plugin via the page ⚙ > Manage Apps > Manage Apps to resolve the issue.

Updated on March 10, 2025

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