Assign Issue Types to <Workflow> Does Not Work Correctly

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Platform Notice: Data Center Only - This article only applies to Atlassian products on the Data Center platform.

Note that this KB was created for the Data Center version of the product. Data Center KBs for non-Data-Center-specific features may also work for Server versions of the product, however they have not been tested. Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.

*Except Fisheye and Crucible


Problem

When assigning issue types to a workflow name in a given JIRA project, the selected Issue Type does not get added or Jira associates a different custom issue type to the workflow.

Diagnosis

Here are the steps to identifying the issue:

  1. Go to a project > project administration > workflows
  2. Add Workflow > Add Existing > Select Workflow
  3. Add an Issue Type

OR

  1. If there is more than 1 workflow, click Assign under Issue Types
  2. Add an Issue Type

The steps should result in the wrong Issue Type being added to a given workflow.

Cause

This problem is caused by some third-party Add-ons, like Zephyr, Calendar for JIRA or Agile Filters for Jira plugin

Workaround

#1

You can use the Workflow Scheme edit screen from the Administration menu instead of using the Project > Workflows screen.


#2

  1. Disable the mentioned Add-ons
  2. Associate the Issue Type to the Workflow
  3. Enable back the Add-ons


Resolution

Zephyr will address the issue in a next release of the plugin.

The bug SUP-35620 has been opened with Teamlead from Calendar for JIRA.



Last modified on Mar 7, 2022

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