Assignee field of imported issues are set to unassigned after running project import
Symptoms
User runs the Project Import tool to import a project, and issues in that project all have the assignee field set to respective users. However, after the project import tool completes, the imported issues in the target instance have their assignee field set to "unassigned".
Diagnosis
- The log files show that the project import completes successfully without errors.
- Disabling third party plugins before performing the import does not help.
Cause
This is caused by the target instance project's issue-type Workflow containing a post-function called "The Assignee of The Issue Will Be Cleared" in the "Create Issue" transition.
Resolution
- The best way to resolve this is to remove the post-function in the create issue transition of the workflow before starting the Project Import process.
- You can re-add the post-function after the Project Import process completes.
Last modified on Feb 26, 2016
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