Auto Assign is Going to Wrong User

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Symptoms

An issue is getting assigned to the wrong user, despite the user being deactivated or removed from Groups and Project Roles that are associated with the Project. The user may have even been deactivated or deleted, but is still being assigned to the Issue. This user is also not listed in any other significant role within the project, such as a Project Lead, nor is this user listed as the Default Assignee.

 

Sometimes the user is a valid user for the Project, but the Issue assignment is still going to the wrong user. This problem can occur even if the Default Assignee in Project Roles > Default Assignee is set correctly. A Workflow Post Function can override that setting.

Diagnosis

There are many ways a user can be assigned to an Issue. If this user has been deactivated or removed from all of the Groups and Roles associated with the project, and is still being assigned Issues, then the user is most likely explicitly listed in a development area of the Project, such as in the Workflow Post Functions.

Cause

Although it's not good development practice to explicitly list users in the development area of your Projects, sometimes user's names are put in those areas.

Resolution

Having an understanding of Advanced Workflow Post Functions can be helpful when editing the configuration of Post Functions.

  1. Go to Administration > Issues > Workflows, and find the Workflow that is associated with the project scheme that is sending the notifications.
  2. Click "Edit" under the Operations column.
  3. This will take you to the main screen for transitions (see screenshot). From here, any number of Post Functions for various activities can be put into place.
  4. To edit the Post Function for the "Create" event, you can click on the first step under the Step Name (id) column. It is typically titled "To Do". From there you can then click on the "Create" event. 
  5. On the next screen you will see a tab titled "Post Function". If you click on that, you can see what Post Functions are associated with the "Create" transition. From there you can create a Post Function or edit the existing one.

There can also be any number of ways to assign a Post Function to a transition, since there are many ways an issue can be transitioned. Additionally, there are more Post Functions that can be applied to the Transitions (id) column, too. For example if you click on "In Progress", there's an option for a Post Function there. As you can see from the screenshot, there are several places on this screen with hyperlinks, and virtually all of them have Post Function options in them. If you don't know what event is creating the auto assign, you may need to look in all of the hyperlinks.

Related Content

For those experienced with XML, there may be a faster way to find where the user is listed explicitly in a Workflow. You can export and import your workflow via XML. Once you've exported the workflow, you can take it into an HTML/XML editor, and do a find inside the XML file to remove the user. From there, you can save it, and import it back into JIRA. Exercise caution when doing this, since adding additional outside steps does introduce the opportunity for error.

Last modified on Nov 1, 2018

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