Cannot Login to JIRA after Upgrade due to Null Pointer Exception

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Symptoms

At the 96% mark of an otherwise successful upgrade, the upgrade is interrupted and the following is seen in the browser:

A system error has occurred.

If this problem persists, please contact your JIRA administrators.

Otherwise, please create a support issue on our support system at http://support.atlassian.com with the following information:

    a description of your problem
    cut & paste the error and system information found below 

Cause:
java.lang.NullPointerException

Stack Trace: [hide]

java.lang.NullPointerException
	at com.atlassian.crowd.embedded.core.CrowdDirectoryServiceImpl.storeLdapConnectionPoolConfiguration(CrowdDirectoryServiceImpl.java:308)
	at com.atlassian.crowd.embedded.core.CrowdDirectoryServiceImpl.initialiseConnectionPoolSystemProperties(CrowdDirectoryServiceImpl.java:291)
	at com.atlassian.crowd.embedded.core.CrowdDirectoryServiceImpl.getApplication(CrowdDirectoryServiceImpl.java:263)
	at com.atlassian.crowd.embedded.core.CrowdDirectoryServiceImpl.findAllDirectories(CrowdDirectoryServiceImpl.java:81)
	at com.atlassian.jira.user.util.DefaultUserManager.getWritableDirectories(DefaultUserManager.java:261)
	at com.atlassian.jira.user.util.DefaultUserManager.hasPasswordWritableDirectory(DefaultUserManager.java:277)

Diagnosis

This is seen when the restore includes the osuser.xml file, but the External User Management flag is not set to True.

Cause

This is caused by the absence of an Internal directory configuration in the osuser.xml file.

Resolution

  1. Remove the osuser.xml file.

  2. Restart JIRA.
Last modified on Mar 30, 2016

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