Connector for Salesforce and JIRA No Longer Syncing
Platform Notice: Cloud - This article applies to Atlassian products on the cloud platform.
Symptoms
Receiving a 'null' error when clicking on the Salesforce Application Link and unable to sync or associate cases between SalesForce and JIRA. Testing the connection to the Salesforce site indicates it is successful.
Diagnosis
When you attempt to run the "Configuration Wizard" it fails and generates another 'null' error. JIRA logs show an HTTP 404 Error when trying to access the Salesforce Instance.
Resolution
- Edit the Cloud Connection to the Salesforce Environment and select "Update".
- After the page refreshes, check that the Configuration Wizard opens successfully. The Sync between Salesforce and JIRA should now be working.